Zyxel P-660HW-T7C (Arcor-Gerät) als Bridge/Access Point

Dieses Thema im Forum "Zyxel und OEM Teledat" wurde erstellt von shiftEWS, 26. Januar 2010.

  1. shiftEWS

    shiftEWS Starter

    Registriert seit:
    26. Januar 2010
    Beiträge:
    6
    Punkte für Erfolge:
    1
    Hallöle an alle Technik-Freaks,

    ich werde bald in eine neue Wohnung ziehen, wo die Zugangsmöglichkeit zum Internet über ein WLAN serviert wird.

    Ich möchte nun aber nicht für jedes Gerät einen WLAN-USB-Stick oder ähnliches kaufen, sondern über meinen Zyxel-Router Zugriff zum Haus-WLAN - also zum Internet - realisieren.

    Netz 1: Ist das WLAN- Netz vom gesamten Haus, über das alle Bewohner ins Internet kommen
    Netz 2: Ist mein internes LAN

    Netz 1 <- - - > WLAN-Router von Zyxel <- - -> Netz 2

    Ich glaube, in der Netzwerktechnik nennt man so eine Funktionsweise Bridge ?!?

    Frage 1: Ist es überhaupt möglich, meinen alten WLAN-Router so zu nutzen?
    Frage 2: Wenn nein, was wäre eine preiswerte Alternative dazu?
     
  2. Chris1

    Chris1 Super-User

    Registriert seit:
    16. März 2003
    Beiträge:
    12.177
    Punkte für Erfolge:
    166
    Hallo,

    Welcome in the Forum.
    Net ganz, das währe dann eine direkte WLAN Verbindung zwischen 2 WLAN Getäten. Da der Router vom Haus aber noch die anderen Clients mit WLAN versorgt ist das eher ein Client Betrieb wo du noch das LAN anzapfst.

    Der Zyxel muss also den Client Betrieb können damit er sich problemlos am vorhandenen WLAN Router anmelden kann.
    Bei einem gebrandeten Router kann ich mir das schlecht vorstellen. Darfst selber mal m WLAN Menü des Zyxel stöbern...

    Was du brauchst ist ein AP mit Client Modus.
    Wenn du an das Gerät gleich deine LAN Rechner anschließen willst schau dir mal -dieses- Gerät an.
    Oder du verwendest einen WLAN AP (ab 20€ für 54Mbit und ab 40€ für 300Mbit) und deine vorhandene Zyxel als LAN Switch.

    Im "Universalrepeater Modus" währe der Edimax Client zum vorhandenen WLAN, LAN Switch für deine Rechner und WLAN Access Point falls du doch mal ein WLAN Gerät oder WLAN Handy hast.

    Bye Chris
     
  3. shiftEWS

    shiftEWS Starter

    Registriert seit:
    26. Januar 2010
    Beiträge:
    6
    Punkte für Erfolge:
    1
    Habe ich getan. Hast recht, habe nichts dergleichen gefunden.

    Da ich schon einen LAN-Switch habe, soll es wohl dieses Gerät werden.
     
  4. Chris1

    Chris1 Super-User

    Registriert seit:
    16. März 2003
    Beiträge:
    12.177
    Punkte für Erfolge:
    166
    Hallo,

    Auch ne gute Wahl :up:

    Bye Chris
     
  5. Tom2009

    Tom2009 Starter

    Registriert seit:
    7. Juli 2009
    Beiträge:
    8
    Punkte für Erfolge:
    1
    Dieses Gerät ist wirklich super. Ein guter Freund von mir ist nämlich vor kurzem in eine Mietwohnung in Bochum gezogen und da hat er sich auch dieses Gerät zugelegt. Das funktioniert wirklich einwandfrei. Er hat sich nämlich vorher ein anderes gekauft (weiß jetzt leider nicht welches) aber das hat nicht gut funktioniert.
     
  6. shiftEWS

    shiftEWS Starter

    Registriert seit:
    26. Januar 2010
    Beiträge:
    6
    Punkte für Erfolge:
    1
    Hi, ich hoffe, dieses Topic wird noch gelesen. Ist ja schon eine Weile her, aber meine finanzielle Situation hat es leider nicht eher erlaubt, mir das Gerät zu kaufen. Naja, jetzt habe ich es zuhause, bin aber ein wenig gefrustet, da ich es noch nicht richtig einstellen konnte.

    Ich schildere nochmal mein Problem mit etwas mehr Details:
    Ich möchte meine Rechner über ein kabelgebundenes LAN, das von einem LAN-Router gemanaged wird (u.a. DHCP) mit einem WLAN verbinden, um darüber ins Internet gehen zu können.

    1. Welcher Betriebsmodus ist am besten? "Universalrepeater" öffnet ja gleich noch ein zweites WLAN-Netz, was aber für meine Problemstellung garnicht notwendig ist. Der “Station-Infrastructure mode” ist glaube ich ganz gut geeignet. Es heisst im Handbuch dazu "it can let your network device join a wireless LAN through an access point"

    2. Der WLAN Router des Hauses hat die IP 192.168.2.1 und liefert ein WPA/WPA2 verschlüsseltes Signal. Nur, wie stelle ich den Edimax jetzt richtig ein? Folgende Einträge sind zu machen: Im Einstellungsfenster des Station-Infrastructure-Mode wird nach ESSID und WLAN MAC gefragt. Sind damit die Daten vom vorhandenen WLAN-HAUS-Router gemeint?

    3. In den System Utilities wird unter "Management IP Adress" nach
    - IP
    - Subnet Mask
    - Gateway Adress
    - DHCP Server (ja/nein) gefragt.

    Unter "DHCP Server" wird noch nach anderen Daten gefragt. Wohl gemerkt, dem einzigen Gerät, dem der Access Point über ein normales RJ-45 Kabel eine IP geben muss ist meinem LAN Router. Alternativ dazu könnte man doch auch einstellen, das beide Geräte immer über die gleiche (also feste) IP kommunizieren, oder?

    Meinen Router stellle ich dann so ein, das er weiss, "aha, unter dieser IP finde ich das Internet. Dieses stelle ich jetzt an einem anderen Port von mir einem anderen Netz (nämlich meinem LAN-Switch an dem meine Rechner und mein Drucker hängt) zur Verfügung."

    Mein Router (Webinterface unter 192.168.0.1 zu erreichen) mit
    PORT A: hier hängt mein LAN Switch und Geräte mit IP-Adressen wie (192.168.0.4, 192.168.0.6, 192.168.0.7)

    PORT B: hier hängt der AP von Edimax (Webinterface standardmäßig auf 192.168.2.1) dran, um die Verbindung zum WLAN des Hauses und somit zum Internet herzustellen. Das Webinterface vom WLAN-HAUS-ROUTER ist ebenfalls unter der IP 192.168.2.1 zu erreichen. Vorher hing an diesem Port das DSL-Modem und hat brav seinen Dienst verrichtet.

    Wo muß ich beim Edimax jetzt welche IP, Subnetmask, DNS und welches Gateway einstellen?
     
  7. Chris1

    Chris1 Super-User

    Registriert seit:
    16. März 2003
    Beiträge:
    12.177
    Punkte für Erfolge:
    166
    Hallo,

    Hier wird alles gelesen was einen grünen Punkt hat ;)

    Leider steig ich noch nicht genau dahinter was du machen willst... :confused:
    Soll der Edimax nun als WLAN Brücke für die LAN Rechner herhalten oder verbunden am Port B als WLAN Access Point funktionieren?
    Und welches Gerät ist dein Router? Sind sonst noch WLAN Geräte im Spiel?
    Entscheide dich Bitte, Beschreib es genauer, oder mach ne Zeichnung, so was hilft enorm!!

    Bye Chris
     
  8. shiftEWS

    shiftEWS Starter

    Registriert seit:
    26. Januar 2010
    Beiträge:
    6
    Punkte für Erfolge:
    1
    Hi Chris, Mensch du bist ja gleich wieder zur Stelle - super !!

    Als Anhang zu diesem Post habe ich eine Zeichnung angefertigt, die darstellt, was ich eigentlich will:

    - Das grüne Netz ist mein kabelgebundenes LAN, der SG 560-Router dient als Firewall und als DHCP-Server für mein LAN. An Port A liegt also DHCP im Adressbereich von 192.168.0.10 bis 192.168.0.20 an. Das hatte ich unten in der Hektik etwas mißverständlich beschrieben. In dem grünen Netz gibt es kein WLAN. Hier läuft der gesamte Traffik über normale Netzwerkkabel (im Bild als dicke schwarze Striche dargestellt). Auch der SG560 arbeitet ausschließlich kabelgebunden (siehe Zeichnung).

    - Der Edimax soll sich mit dem HAUS-WLAN drahtlos verbinden, um so den Zugang zum Internet an Port B des SG560-Routers zu servieren. Dieser leitet die Internetverbindung dann weiter an meine Rechner in meinem grünen Netzwerk. Die Weboberfläche des Edimax ist ab Werk unter 192.168.2.1 zu erreichen. Hier fangen meine Konfigurationsschwierigkeiten an, da der HAUS-WLAN-ROUTER (nicht der SG560!!) ebenfalls eine Weboberfläche unter 192.168.2.1 serviert.

    Welcher Betriebsmodus vom Edimax genügt meinen Vorstellungen?
     

    Anhänge:

    • wlan.jpg
      wlan.jpg
      Dateigröße:
      39,3 KB
      Aufrufe:
      1.680
  9. frank.td

    frank.td Moderator

    Registriert seit:
    30. Dezember 2006
    Beiträge:
    35.220
    Punkte für Erfolge:
    780
    Hallo,

    Chris hat dir schon den entscheidenden Ansatz geliefert. Du musst den Universalrepeater in den IP-Bereich von deinem LAN bringen. Dann sollte es klappen. Außerdem im Universalrepeater DHCP ausschalten.
    Die IP-Vergabe erfolgt dann über den Router automatisch oder du vergibst jedem Adapter eine eigene statische IP.

    Die Änderung der IP im Universalrepeater erledigst du am besten, wenn du den Repeater direkt mit dem PC via Kabel verbindest.

    Gruß Frank
     
  10. shiftEWS

    shiftEWS Starter

    Registriert seit:
    26. Januar 2010
    Beiträge:
    6
    Punkte für Erfolge:
    1
    Hi,

    also als ich vorher einen DSL Router an Port B angeschlossen hatte, ging das auch. Mein Router SG560 kann ja an Port A und B vollkommen unterschiedliche Netze managen. Er muss halt nur wissen, das an Port B das Internet anliegt, damit die richtigen Firewalleinstellungen genommen werden. Kommen aus dem LAN an Port A IP-Anfragen, die nicht weiter aufgelöst werden können, wurden diese dann automatisch an Port B geroutet. Ich möchte den Universalrepeatermodus aus dem Grund, den ich unter "Zitat" in meinem letzten Post markiert habe, nicht verwenden.

    Danke für deinen Lösungsansatz Frank, er entspricht aber leider nicht meinem Ziel.
    Die Einstellungen am Edimax AP nehme ich so vor, wie du schon beschrieben hast - in direkter Verbindung zu einem PC.

    Also nochmal ganz klar: ICH MÖCHTE KEIN NEUES WLAN mit dem AP realisieren. Ich möchte, das der AP eine Verbindung zum bestehenden WLAN aufbaut, an die mein LAN Router dann Internetaufrufe routen kann, die aus meinem LAN (Bild: grün) kommen.
     
  11. Chris1

    Chris1 Super-User

    Registriert seit:
    16. März 2003
    Beiträge:
    12.177
    Punkte für Erfolge:
    166
    Hallo,

    Bei der Konfig kannste auch den "Station Mode Infrastrukture" nehmen, dann haste eine direkte WLAN Verbindung zum "Haus-Wlan" und keine Bandbreitenhalbierung wie beim Repeater Modus.

    Im Edimax musst du dann nur die LAN IP auf 192.168.2.xx einstellen und den DHCP Server deaktivieren!!
    Gateway ist die IP des WLAN Routers 192.168.2.1, Subnet 255.255.255.0
    SSID und Passwort wie im Router vom Haus WLAN.
    Probier die Verbindung ins Internet erst mal direkt mit einem Rechner am Edimax. Erst wenn die geht den 2. Router ranhängen

    Wenn du am Router den Port B als WAN Port konfigurierst um damit ein Subnet mit separatem IP Bereich zu erreichen ist das OK.
    Im Router SG 560 musst du dann "Dynamische IP" als Internetzugang einstellen. die WAN IP bekommste dann vom DHCP Server des WLAN Routers.
    Kannst aber auch eine statische WAN IP einstellen, Gateway und DNS Server ist die IP des WLAN Routers 192.168.2.1
    Mit den Rechnern hinter dem 2. Router kommste dann halt nicht mehr in die Konfig vom WLAN Router!

    Wenn du kein Subnet haben willst kannste den Router auch weglassen und den Edimax direkt an den Switch einstecken, dann musst du halt die LAN IPs deiner Clients an den IP Bereich 192.168.2.xx anpassen.

    Mit den Infos solltest du eigentlich zurecht kommen... Wenn nicht nochmal melden.

    Bye Chris
     
  12. shiftEWS

    shiftEWS Starter

    Registriert seit:
    26. Januar 2010
    Beiträge:
    6
    Punkte für Erfolge:
    1
    @Chris: Bin nach dem Rezept vorgegangen und es funktioniert :)
    "Dynamischer IP als Internetzugang" beim SG560 konnte ich leider nicht lauffähig einstellen, aber mit einer statischen gehts ja auch.
    Habe jetzt nur noch ein anderes Problem, aber das gehört eigentlich auch in ein anderes Forum. Mit Win Vista sowie Linux Element habe ich prima Internetzugang, aber mit Debian Linux Lenny (meinem favorisierten OS) dauert der Zugriff unheimlich lange. Viele Seiten brauchen 2 Minuten oder länger, bis sie ganz aufgebaut sind. Das war vorher mit dem DSL Modem an Port B nicht der Fall. Falls noch jemand interessante Links dazu hat, gerne posten.

    Gibts bei euch eine Markierung für "Beitrag erledigt" oder "gelöst"?
     
  13. Chris1

    Chris1 Super-User

    Registriert seit:
    16. März 2003
    Beiträge:
    12.177
    Punkte für Erfolge:
    166
    Hallo,

    Freut mich dass es endlich funktioniert.
    Nö eigentlich nicht.
    Man könne den Thread sperren, das wird aber nur in seltenen Fällen gemacht wenn man die Board Regeln missachtet.

    Wenn doch noch Probleme auftauchen kannste den Thread weiterführen, dann weiss man wenigstens was vorher schon probiert wurde.

    Bye Chris