Physisches Gast-WLAN einrichten und isolieren

Dieses Thema im Forum "WLAN Technik" wurde erstellt von Paspartan, 20. Dezember 2018.

  1. Paspartan

    Paspartan Starter

    Registriert seit:
    20. Dezember 2018
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Hallo zusammen,
    ich bin neu hier bei euch im Forum, habe aber hier schon den ein oder anderen Beitrag mitgelesen.
    Ich stehe zum ersten Mal seit längerem auf dem Schlauch, wie ich unser Heimnetz konfiguriern soll.
    Vielleicht habt ihr Profis ja eine Anregung, wie ich dem "Wildwuchs" bei uns etwas Struktur verleihen kann.

    Zunächst kurz zum aktuellen Setup:
    Keller Internetzugang:
    Wir haben eine b-box3-modem von unserem beglischen ISP im Keller, die den Internetzugang und ggfs. W-Lan und 4xLan zu Verfügung stellen kann. Der ISP hat die Konfigurationsmöglichkeiten zwar eigeschränkt, aber die rudimentären Basiscs, DHCP, DMZ, WLAN kann/könnte man aber immerhin konfigurieren.
    1.OG Nutzer
    Die Box ist per cat5e und über einen Noname Switch (Keller > 1.OG ca. 15mKabel) mit einem TpLink TL-WR1043ND (DD-WRT v24SP2) verbunden. Der DD-WRT Router versorgt die Geräte des 1.OG per Lan und und W-Lan. (Drucker, NAS, Mediengeräte, etc.)
    (EG Nutzer)
    Im EG wird nur W-Lan genutzt, teilweise über den DD-WRT, teilweise über das indes aktivierte WLAN der Bbox im Keller.
    (Nicht ideal, aber flotter als alles über den AP im 1.OG laufen zu lassen, abgesehen von der Reichweite)
    Dieses Setup lief seit einigen Jahren gut.
    Gäste
    Da wir häufiger Gäste haben, denen ich ermöglichen möchte online zu gehen, habe ich auf dem DD-WRT ein zusätzliches und isoliertes GästeWLAN eigerichtet.
    Da sich das Gästezimmmer aber am Emfangsrand befindet, häufen sich aber die Klagen, dass der Gastzugang entweder nicht erreichbar oder sehr lahm sei. Keine Ahnung, ob das an der Performance des DD-WRT Routers oder generell an der Reichweite liegt. Vermutlich beides. Insgesamt sind es schon so 10-15+ Verbindungen/Geräte/Nutzer, aber selten simultan.
    Randbemerkung:
    DHCP läuft über die Box im Keller, der DD-WRT ist reiner AP. Der Bbox und dem DD-WRT habe ich statische IPs außerhalb der der DHCP Range zugewiesen.

    Neues physisches Gästenetz mit alten WLanAP

    Ich habe mir nun überlegt, dass ich einen alten TP-Link TL-WA801ND (300mpsWLANAP) verwenden möchte, um damit ein zweites Gästenetz aufzubauen, das idealerweise auch das GastWLAN aus dem 1.OG ersetzen soll. Der AP ist im EG und hängt über DLan an der Bbox im Keller (Eigentlich nur als Test gedacht, Kabel ist räumlich schwer zu realisieren) Jetzt würde ich die beiden physischen Netze, die im Keller an der BBox hängen (1.OG DD-WRT und den DLAN TP-Link) gerne isolieren, damit Gäste und Nutzer sich nicht in die Quere kommen.
    Die Umsetzung hatte ich mit recht einfach vorgestellt: Ich habe 19€ in einen Zyxsel GS1200-5 smart switch investiert, da ich dachte, den hänge ich zwischen BBox und die beiden APs. Mittlerweile bin ich allerdings eines Besseren belehrt und stehe mit meinem Halbwissen auf dem Schlauch.
    Vielleicht habt ihr ja einen Tipp, ob ich den SmartSwitch überhaupt verwenden kann, und wie ich ihn ggfs. konfiguriere.
    Ich habe jetzt einige Tutorials gelesen, bin aber etwas überfordert, da in vielen Fällen anscheinend auch der Router, der zum Internet verbindet VLan-fähig sein muss.

    Ich bin für jeden Input dankbar und bin mir auch bewusst, dass es eine ziemliche "Frickel"-Lösung ist, allerdings ist die Infrasturktur hier ein wenig gewachsen...

    Das Wlan über die Bbox würde ich erst mal ausblenden. Wenn das Gästenetz über DLan flott genug ist, würde ich einfach ein zweites WLAN auf dem alten TP-Link einrichten, was soweit ich gesehen habe auch mit der Stock Software möglich ist. ​


    Danke und viele Grüße
    Paspartan
     
  2. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.131
    Punkte für Erfolge:
    120
    Hi,

    willkommen im Forum.

    Nach dem Durchlesen deines Anliegens scheint mir - dieser Beitrag - dein Problem zu adressieren. Wenn nicht, kannst du ja noch mal fragen...:)

    VG
     
    Paspartan hat sich bedankt.
  3. Paspartan

    Paspartan Starter

    Registriert seit:
    20. Dezember 2018
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Danke füe den Hinweis auf das hilftreiche Turorial. Ich hab es zwar schon vorher gelesen, hatte aber einen Denkfehler.

    Ich habe heute alles nochmal verkabelt und dem SmartSwitch konfiguriert. Allerdings klappt es noch nicht so recht.
    Vlan1 (Heimnetz) ist an Port 1 mit dem ISP Router (=DHCP Server) und an Port 2 mit unseren Geräten im 1.OG verbunden. Hier klappt alles wunderbar.
    An Port 3 hängt der WifiAP, der das Gästenetz zur Verfügung stellen soll. (Vlan10)
    Clients können leider keine IP-Adresse auf dem GÄsteAP abrufen.
    Wenn ich auf dem GästeAP einen DHCP Server starte gibt es zwar IPs, aber es kann dann keine Verbindung zum Internet hergestellt werden.:'‑(
    Hat jemand eine Idee?
    Muss ich bei dem GästeAP den Gateway auf den ISP Router oder auf den Smart Switch stellen? Ich meine zumindest beides eben ohne Erfolg getestet zu haben... [​IMG]
    Viele Grüße und vielen Dank
     

    Anhänge:

  4. Paspartan

    Paspartan Starter

    Registriert seit:
    20. Dezember 2018
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Sorry für die Fehler, war wohl etwas spät gestern.
    Viele Grüße
     
  5. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.131
    Punkte für Erfolge:
    120
    Hi,

    am AP muss der DHCP-Server ausgeschaltet sein. Welches Modell setzt du als AP ein?

    VG
     
  6. Paspartan

    Paspartan Starter

    Registriert seit:
    20. Dezember 2018
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Hello
    Der Gästezugang hängt an einem TP-Link TL-WA801ND (V1). Alle AP's (Gäste/1.OG), der Zyxl und die BBox (vom ISP) haben eine statische IP im selben Netz. 192.168.1.1-4
    Viele Grüße
     
  7. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.131
    Punkte für Erfolge:
    120
    Hi,
    die Konfiguration des Switches ist i.O. Bist du dir sicher, dass der WA801ND richtig konfiguriert ist? Ist auf dem auch dd-wrt installiert? Das WA801ND ist über einen LAN-Port ohne NAT an den Switch angeschlossen?

    BTW: Der Switch ist für das, was er kann, seeeeehr günstig. Den werde ich mir bei nächster Gelegenheit mal näher anschauen...

    VG
     
  8. Paspartan

    Paspartan Starter

    Registriert seit:
    20. Dezember 2018
    Beiträge:
    5
    Punkte für Erfolge:
    1
    So, ich war die vergangenen Tage etwas beschäftigt...
    Der WA801ND hat nur einen Port, ich bin mir nicht sicher, ob NAT dann zwingend aktiv ist/war
    Auf deinen Frage hin, habe ich kurzerhand dd-wrt aufgespielt: Die Situation ist allerdings unverändert, der AP ist in seinem eigenen Netz wenn ich Ihn über den Zyxel einem separaten Netz zuordne.
    Für das eigentliche Problem habe ich jetzt dank dd-wrt eine Lösung gefunden: Ich habe ein zusätzliches, "sicheres" Gast-Wlan eingerichtet (Anleitung habe ich hier gefunden).
    Nichts desto trotz würde ich weiterhin versuchen, die in meinen Augen elegantere Lösung über den Zyxel zu realisieren. Vielleicht probiere ich auch aus, einen weiteren/anderen Nutzer an den Zyxel zu hängen. (Das wird aber noch dauern) Eine alternative Lösung über Tagging, würde aber, wenn ich das System richtig verstehe, nur funktionieren, wenn auch das Gerät vom ISP Tagging untersützt oder?

    Vielen Dank erstmal und viele Grüße
     
  9. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.131
    Punkte für Erfolge:
    120
    #9 CapFloor, 28. Dezember 2018
    Zuletzt bearbeitet: 28. Dezember 2018
    Hi,

    freut mich, dass du jetzt eine Lösung gefunden hast. Danke für die Rückmeldung.

    Ich halte das für eine ganz gute Lösung, wenn man Router als APs im Einsatz hat - entweder mit Werks-FW oder mit einer Firmware von Drittanbietern. Der einzige "Pferdefuß", der mir aufgefallen ist: Das NAT auf "br0" NATted doch nicht nur das Gast-Subnetz, sondern auch den Netzwerk-Verkehr aus dem Subnetz des Heinnetzes an dem AP, oder? Damit können keine Clients am AP im Heimnetzwerk per DHCP angebunden werden. Ich weiss, ist ja nicht Sinn der Sache, aber trotzdem schade...:(

    VG
     
  10. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.131
    Punkte für Erfolge:
    120
    Hi,
    Nein, nicht unbedingt. Besser ist das zwar, aber als Behelfslösung reich eine Switch Unterstützung für VLANs - darum geht es ja in meinem weiter oben verlinkten Beitrag;).

    VG
     
  11. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.131
    Punkte für Erfolge:
    120
    Hi,
    Nach nochmaligem Nachdenken - fast immer hilfreich :rolleyes: - ist das, was ich da geschrieben haben, falsch. Der Netzwerk-Verkehr innerhalb der Bridge "br0" wird natürlich nicht geNATted, sondern nur der, der aus der Gast-Bridgegruppe "br1" kommt.

    Deshalb können sich selbstverständlich auch Clients im Heimnetzwerk per DHCP über den AP anmelden.

    VG