Möchte mit Flugsimulator hosten

Dieses Thema im Forum "Online-Games über Router" wurde erstellt von Oldspeedy, 7. Februar 2010.

  1. Oldspeedy

    Oldspeedy Starter

    Registriert seit:
    7. Februar 2010
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Ich fliege sehr gerne in der Hyperlobby mit dem Flugsimulator IL 2 Sturmovik 1946.
    Mit einer DSL - Flatrate und einem Samsung - Router SMT G 3010 auch alles kein Problem.
    Als passiver Mitspieler. -
    ABER ===>>> ich würde unheimlich gerne selber mal Spiele hosten.
    Wie so viele es tun .
    Das ist auch in der Hyperlobby einfach und problemlos möglich.
    Es scheitert aber an den Routereinstellungen - da bin ich nicht kompetent .
    Ich weiss, dass ich TCP Port 21000 und UDP Port 21000 freischalten muss. Hab ich getan.
    Dazu gesellt sich dann meine IP Adresse , die ich über My IP abfrage und dann kenne.
    Die Windowsfirewall von Win XP ist auch schon frei für diese Ports ---
    aber es geht und geht NICHT !!!
    Irgendetwas mache ich da immer noch falsch.
    Deshalb bitte ich hier um Hilfe für dieses Spielehostproblem .
    Vielen Dank für Eure Mühe !
     
  2. pez

    pez Super-User

    Registriert seit:
    29. März 2002
    Beiträge:
    15.828
    Punkte für Erfolge:
    166
    wozu brauchst du deine WAN-IP für die Port-Weiterleitung ?

    dein Rechner sollte eine fixe IP haben, nicht DHCP vom Router und nur diese LAN-IP brauchst du bei der Portfreigabe unter Firewall im Router-Menü eintragen, bzw. kannst dort glaub ich sogar den Rechner direkt auswählen...

    testweise WIN-Firewall mal komplett deaktivieren, andere Firewalls deinstallieren...
    testweise auch mal mit "DMZ"-Funktion des Routers probieren...
     
  3. Oldspeedy

    Oldspeedy Starter

    Registriert seit:
    7. Februar 2010
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Hallo Pez - vielen Dank für deine Antwort !
    Versiert bin ich halt nicht - was ist denn bitte eine WAN - IP ?
    Gedacht hatte ich mir folgendes :
    Wenn andere Spieler auf mein gehostetes Spiel zugreifen wollen / sollen,
    dann muss ich doch die IP - Adresse zum Portfreischalten verwenden,
    unter der ich im Internet bin . -----
    Also habe ich meine IP ausfindig gemacht und die war damals :

    77.182.174.58 -- Germany . 1 & 1 . usw. usw.

    Diese IP habe ich dann im Router zur Freischaltung benutzt .

    Nun begreife ich aber, dass ich wohl die IP von meinem PC - LAN nehmen muss.
    Das ist aber doch die, die mein PC intern für die Verbindung zum Router nutzt !
    Die habe ich auch schon notiert, die heisst :

    192.168.220.1

    Muss ich diese letzte, interne LAN IP Adresse nehmen ?

    Anyhow ==> recht aufrichtigen Dank für deine Hilfe.
    Wenn das Hosten mal klappt, freut sich der Papa aber heftig :) :)
     
  4. pez

    pez Super-User

    Registriert seit:
    29. März 2002
    Beiträge:
    15.828
    Punkte für Erfolge:
    166
    richtig, deine LAN-IP mußt du nehmen, damit der Router weiß, wohin er die Internetanfragen bezüglch des Games weiterleiten soll, eben zu deinem Game-Rechner...
    denn die Game-Anfragen aus dem INet läßt die Firewall des Router dann zu deinem Rechner durch, auf dem eingestelltem Port;

    allerdings, bist du sicher, das dein Rechner die 192.168.220.1 hat ?
    kannst einfach kontrollieren unter Start - Ausführen:
    cmd /k ipconfig /all (OK)
    dort steht bei deinem LAN-Adapter dann unter anderem deine Rechner-IP, du kannst das Ergebnis auch hier posten (rechtsklick ins Fenster, alles markieren, hier einfügen)

    und wie gesagt, solltest die IP in den Eigenschaften des LAN-Adapters fix (statisch) eintragen, damit sie sich nicht ändern kann, denn sonst wäre die Weiterleitung sinnlos...

    deine WAN-IP (die im INet sichtbar ist) ändert sich ja täglich bei jeder Zwangstrennung vom Provider...
     
  5. Oldspeedy

    Oldspeedy Starter

    Registriert seit:
    7. Februar 2010
    Beiträge:
    5
    Punkte für Erfolge:
    1
    :D :D :D Super - da haben wir ja den ersten dicken Fehler schon erwischt !
    Ich hatte immer die WAN-IP genommen !
    Nun habe ich den Lanbefehl mal ausgeführt und da kam dann dieses hier zurück :
    ...................................................................................................................
    Hostname. . . . . . . . . . . . . : Blechkopf
    Primäres DNS-Suffix . . . . . . . :
    Knotentyp . . . . . . . . . . . . : Unbekannt
    IP-Routing aktiviert. . . . . . . : Nein
    WINS-Proxy aktiviert. . . . . . . : Nein
    DNS-Suffixsuchliste . . . . . . . : samsung.router

    Ethernetadapter LAN to ROUTER:

    Verbindungsspezifisches DNS-Suffix: samsung.router
    Beschreibung. . . . . . . . . . . : Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC
    Physikalische Adresse . . . . . . : 00-18-F3-08-51-2F
    DHCP aktiviert. . . . . . . . . . : Ja
    Autokonfiguration aktiviert . . . : Ja
    IP-Adresse. . . . . . . . . . . . : 192.168.220.100
    Subnetzmaske. . . . . . . . . . . : 255.255.255.0
    Standardgateway . . . . . . . . . : 192.168.220.1
    DHCP-Server . . . . . . . . . . . : 192.168.220.1
    DNS-Server. . . . . . . . . . . . : 192.168.220.1
    Lease erhalten. . . . . . . . . . : Mittwoch, 10. Februar 2010 23:10:10
    Lease läuft ab. . . . . . . . . . : Donnerstag, 11. Februar 2010 23:10:10
    .............................................................................................................................
    wie kann ich denn nun die LAN - Verbindung statisch fixieren ??

    IM BIOS ???

    Sorry for Dummkopf :) Vielen Dank für deine Hilfe !!!!!
     
  6. pez

    pez Super-User

    Registriert seit:
    29. März 2002
    Beiträge:
    15.828
    Punkte für Erfolge:
    166
    ;) dachte ich mir doch, das dein Rechner nicht die x.1 hat, Rechner hat x.100 und der Router hat x.1

    Systemsteuerung - Netzwerkverbindungen - LAN-Verbindung - Eigenschaften - INetprotokoll-TCP/IP (Eigenschaften)
    Eingabe machst wie am Bild....
     

    Anhänge:

    • TCPIP.jpg
      TCPIP.jpg
      Dateigröße:
      31,8 KB
      Aufrufe:
      229
  7. Oldspeedy

    Oldspeedy Starter

    Registriert seit:
    7. Februar 2010
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Danke schön, das habe ich gemacht und bin nun wohl nah am Erfolg,
    aber das Spiel läuft noch nicht online.
    Auch die anderen Tipps habe ich ausprobiert:
    Windowsfirewall abgeschaltet und auch DZM - Modus aktiviert.
    Leider das Gleiche :devil:
    Aber aufgeben kommt nicht in Frage ! :!
    Ob es nun noch am Router liegt ?
    Im Antivirusprogramm AVG habe ich nach Freigaben bzw. Ausnahmen gesucht,
    aber da ist nichts in dieser Art einzustellen.
    Ich hoffe, ich nerve nun nicht :oops:

    Ich bin dankbar für deine Hilfe !

    mit sehr freundlichen Grüßen Oldspeedy
     
  8. pez

    pez Super-User

    Registriert seit:
    29. März 2002
    Beiträge:
    15.828
    Punkte für Erfolge:
    166
    du nervst nicht ;)

    dein Antivirusprogramm AVG hat darauf keinen Einfluß, hat ja keine Firewallfunktion...

    nochmal zur Sicherheit:
    die Portweiterleitung im Router hast jetzt auf die fixe IP deines Rechners gemacht, also auf 192.168.0.100....
    genauso beim Test mit DMZ (keine Firewall am Router), auch auf diese IP ?

    und wenn sonst keine Firewalls am Rechner sind, sollte es eigentlich klappen...

    wenn nicht, muß ich leider passen, ev. findet sich noch jemand mit einem Tipp bzw. hilft dir das Sturmovik-Forum weiter....
     
  9. Oldspeedy

    Oldspeedy Starter

    Registriert seit:
    7. Februar 2010
    Beiträge:
    5
    Punkte für Erfolge:
    1
    Trotz aller Hilfe, für die ich mich nocheinmal ausdrücklich bedanken möchte,
    will es noch nicht klappen mit dem Hosten von IL 2 Sturmovik.
    Am Wochenende werde ich alles erneut mit allen Variationen durchprobieren
    und dann melde ich mich hier zurück für einen Abschlußbericht.
    Andere sollen ja profitieren :D
    Ich bin nah dran und es muß wohl etwas mit Hyperlobby selbst sein.
    Deren Forum ist momentan " not activated ! "
    :devil:
    Danke schön und Grüße aus Siegen im schönen Siegerland ! :p