Eingehende Verbindungen gehen nicht über die externe IP rein, wenn sie von innerhalb kommen

Dieses Thema im Forum "Router & Datensicherheit" wurde erstellt von djtraumwelt, 25. Januar 2010.

  1. djtraumwelt

    djtraumwelt Starter

    Registriert seit:
    25. Januar 2010
    Beiträge:
    4
    Punkte für Erfolge:
    1
    Habe eine Vodafone EasyBox (Firmware Version: 20.02.021 (01.10.2009-15:10:12)) und eingehende Verbindungen zu einer Serveranwendung (wir wollen z.b. Trackmania über eigenen Server spielen) gehen nicht rein, wenn sie von innerhalb des Routers (ein PC, sei es mein eigener oder ein anderer in der WG) kommen und über die externe IP angesteuert werden.

    Ich habe schon gelesen, dass das bei einigen Routern generell nicht geht, weil extern intern hin und her kommen manche einfach nicht klar. Die Sache ist nur die, dass es ging, bis es irgendwann nicht mehr ging.

    Die eingehenden Verbindungen kommen an, wenn man sie über die Interne IP ansteuert (also WG-Mitglieder können per ftp://Alex-PC/ auf meinen FileZilla Server zugreifen, über ftp://externe-IP/ nicht. Hab für externe IP natürlich noch nen dyndns link gesetzt) Die eingehenden Verbindungen von außerhalb gehen auch rein, nur intern klappt das nicht.

    Da man bei Trackmania keine "interne IP" auswählen kann, sondern nur den Server anklicken kann, versucht er immer über extern zu connecten. Das heißt, wir brauchen diese intern extern verbindung recht dringend, zumindest so dringend, wie ein Trackmania Spiel eben ist und das ist schon irgendwo ein bisschen wichtig, da wir unsere selbstgebauten Strecken fahren möchten.

    Irgendjemand ne Idee, woran das liegen kann, dass die eingehenden Verbindungen von intern über externe IP nicht funktionieren? Und vielleicht auch ne Idee, wie ich das wieder zum laufen krieg? (Da es schonmal funktioniert hat, vielleicht Router resetten auf alte Firmware, weiß nicht ob die da mit resettet wird und die updates ausschalten, da es ja eventuell an einem update liegt?)
     
  2. Chris1

    Chris1 Super-User

    Registriert seit:
    16. März 2003
    Beiträge:
    12.177
    Punkte für Erfolge:
    166
    Hallo,

    Welcome in the Forum.

    Hört sich an wie ein NAT-Loopback Problem. Das können nicht alle Router.
    Kannste mal ne AVM vom Kumpel testen?
    Die können das, von intern die Dyndns Adresse oder WAN eingeben und die Verbindung steht.
    Warum das früher mal funktioniert haben soll kann ich dir auch net sagen...

    Bye Chris
     
  3. djtraumwelt

    djtraumwelt Starter

    Registriert seit:
    25. Januar 2010
    Beiträge:
    4
    Punkte für Erfolge:
    1
    also AVM... hab ich erstens keine und zweitens: wie geb ich dann die zugangsdaten ein? ich mein, die easybox verwendet einen installationscode mit dem Fremdrouter nix anfangen können.
     
  4. COMCARGRU

    COMCARGRU Moderator

    Registriert seit:
    8. Juni 2003
    Beiträge:
    1.395
    Punkte für Erfolge:
    38
    Tach,

    Onlinegame ssind nicht so mein Fall, aber zum Verständnis:

    Du mußt im Spiel einen Servernamen angeben und keine IP?

    Wenn ja könntest du in deine Hosts Datei einfach einen Eintrag der Art:

    Interne-IP MeinServer.Domain.TLD

    reinschreiben. Dann hat dein Spiel seinen öffentlichen Servernamen und verbindet trotzdem auf die interne IP - Dann hat dein Router damit nix mehr zu tun!

    Gruß
    COMCARGRU
     
  5. djtraumwelt

    djtraumwelt Starter

    Registriert seit:
    25. Januar 2010
    Beiträge:
    4
    Punkte für Erfolge:
    1
    das geht leider nicht. man klickt im spiel nur auf erstellen und der server läuft und die ip (extern) wird automatisch in der liste auf dem masterserver gespeichert. man kann das nicht manuell machen.
     
  6. djtraumwelt

    djtraumwelt Starter

    Registriert seit:
    25. Januar 2010
    Beiträge:
    4
    Punkte für Erfolge:
    1
    Hab heute ne Firmware aktualisierung gemacht und seit dem funktioniert alles wieder.