MPLS-Netz mit dem RB750 von Mikrotik

Dieses Thema im Forum "Mikrotik" wurde erstellt von der-Bauer, 3. November 2010.

  1. der-Bauer

    der-Bauer Starter

    Registriert seit:
    27. Mai 2010
    Beiträge:
    2
    Punkte für Erfolge:
    0
    Ich habe mir zu Testzwecken 4 Router (RB750) von Mikrotik zugelegt. Auf allen Routern läuft die RouterOS-Version 4.11. Jetzt möchte ich ein MPLS-Netzt mit diesen Routern aufbauen. Die Netzstruktur ist auf dem folgenden Bild zusehen.

    http://yfrog.com/5znetzstrukturj

    alle Subnetze haben Subnetzmaske 255.255.255.0

    Die einzelnen Router sind folgendermaßen konfiguriert.

    Router1

    /system identity set name=Router1
    /ip address add address=10.10.10.1/24 interface=ether1
    /ip address add address=10.10.11.1/24 interface=ether2
    /ip address add address=192.168.1.1/24 interface=ether3
    /ip address add address=192.168.2.1/24 interface=ether4
    /interface bridge add name=lobridge
    /ip address add address=10.10.14.1/24 interface=lobridge
    /routing ospf instance set router-id=10.10.14.1 numbers=default
    /routing ospf network
    add area=backbone network=10.10.10.0/24
    add area=backbone network=10.10.11.0/24
    add area=backbone network=192.168.1.0/24
    add area=backbone network=192.168.2.0/24
    #MPLS
    /mpls ldp set enabled=yes lsr-id=10.10.14.1 transport-address=10.10.14.1
    /mpls ldp interface add interface=ether1
    /mpls ldp interface add interface=ether2



    Router2

    /system identity set name=Router2
    /ip address add address=10.10.10.2/24 interface=ether1
    /ip address add address=10.10.13.1/24 interface=ether2
    /interface bridge add name=lobridge
    /ip address add address=10.10.14.2/24 interface=lobridge
    /routing ospf instance set router-id=10.10.14.2 numbers=default
    /routing ospf network
    add area=backbone network=10.10.10.0/24
    add area=backbone network=10.10.13.0/24
    #MPLS
    /mpls ldp set enabled=yes lsr-id=10.10.14.2 transport-address=10.10.14.2
    /mpls ldp interface add interface=ether1
    /mpls ldp interface add interface=ether2



    Router3

    /system identity set name=Router3
    /ip address add address=10.10.11.2/24 interface=ether1
    /ip address add address=10.10.12.1/24 interface=ether2
    /interface bridge add name=lobridge
    /ip address add address=10.10.14.3/24 interface=lobridge
    /routing ospf instance set router-id=10.10.14.3 numbers=default
    /routing ospf network
    add area=backbone network=10.10.11.0/24
    add area=backbone network=10.10.12.0/24
    #MPLS
    /mpls ldp set enabled=yes lsr-id=10.10.14.3 transport-address=10.10.14.3
    /mpls ldp interface add interface=ether1
    /mpls ldp interface add interface=ether2


    Router4

    /system identity set name=Router4
    /ip address add address=10.10.13.2/24 interface=ether1
    /ip address add address=10.10.12.2/24 interface=ether2
    /ip address add address=192.168.3.1/24 interface=ether3
    /ip address add address=192.168.4.1/24 interface=ether4
    /ip address add address=192.168.5.1/24 interface=ether5
    /interface bridge add name=lobridge
    /ip address add address=10.10.14.4/24 interface=lobridge
    /routing ospf instance set router-id=10.10.14.4 numbers=default
    /routing ospf network
    add area=backbone network=10.10.12.0/24
    add area=backbone network=10.10.13.0/24
    add area=backbone network=192.168.3.0/24
    add area=backbone network=192.168.4.0/24
    add area=backbone network=192.168.5.0/24
    #MPLS
    /mpls ldp set enabled=yes lsr-id=10.10.14.4 transport-address=10.10.14.4
    /mpls ldp interface add interface=ether1
    /mpls ldp interface add interface=ether2


    Das normale Routing per OSPF läuft aber MPLS läuft nicht. Was mache ich falsch?
    Ich hoffe, dass mir einer von euch helfen kann.