Tomato auf Linksys funktioniert nicht?!

Dieses Thema im Forum "Linksys" wurde erstellt von Pratze, 16. Februar 2010.

  1. Pratze

    Pratze Starter

    Registriert seit:
    16. Februar 2010
    Beiträge:
    3
    Punkte für Erfolge:
    1
    Hallo allerseits,

    ich habe für meine Eltern einen WRT54GL gekauft. Jetzt wollte ich unbedingt die Sendeleistung erhöhen und daher Tomato draufspielen. Nur bin ich echt am verzweifeln, weil ich es nicht einmal schaffe, die Firmware installieren zu können. Zum einen wird mir immer wieder gesagt, dass *.7z keine gültige Konfigurationsdatei sei. Auch eine Umbenennung in *.bin hat nur zu einem Fehlschlagen der Aktualisierung geführt -> Router funktioniert aber noch. Auch ein Hardwarereset hatte ich durchgeführt (30sek. halten), hat aber auch nichts gebracht. Ich habe verschiedene Versionen von Tomato (alle aber mit *.7z-Endungg) ausprobiert, er nimmt keine Datei von vornherein an.
    Was mache ich falsch?

    Danke für eure Antworten

    Pratze
     
  2. frank.td

    frank.td Moderator

    Registriert seit:
    30. Dezember 2006
    Beiträge:
    35.151
    Punkte für Erfolge:
    780
    Hallo,

    willkommen im Forum.

    *.7z ist ein Dateiformat von dem Komprimierungsprogramm 7-Zip. Diese Datei muss erst entpackt werden, damit du die andere Datei verwenden kannst.
    Das kostenlose Programm 7-Zip findest du -hier-

    Gruß Frank
     
  3. MasterJM

    MasterJM Power-User

    Registriert seit:
    15. April 2005
    Beiträge:
    1.056
    Punkte für Erfolge:
    36
    was frank sagte und zur Ergänzung:
    Tomato läuft seit Jahren auf meinen 54GLs


    Sendeleistung per Software höher setzen bringt btw gar nichts IMHO.
     
  4. Pratze

    Pratze Starter

    Registriert seit:
    16. Februar 2010
    Beiträge:
    3
    Punkte für Erfolge:
    1
    Vielen vielen Dank an euch.
    Es ist so deprimierend, wenn man über 2 Stunden verschiedenste Dateien ausprobiert oder umbenennt, in hunderten Beiträgen liest, dass die Installation so einfach wäre usw.
    Werde ich sobald ich bei den Eltern bin, mal wieder ausprobieren.

    @MASTERJM
    Ich dachte gelesen zu haben, dass die Funktion afterburner oder die Einstellung der mw-werte vielleicht ein bisschen mehr signalstärke verleihen kann. Der Router ist dummerweise im ersten Stock und der empfänger sitzt im Erdgeschoss, schräg unten drunter, muss allerdings durch 2 wände/decken hindurch.
    Wenn die Funktion in Tomato nichts bringen sollte, möchte ich entweder einen Repeater zwischenschalten um das Erdgeschoss zu bestrahlen, oder ich tausche den AVM USB-Stick gegen eine pcikarte mit besserer Antenne aus. Was würdert ihr mir empfehlen, sowohl beim Repeater (dachte hier an das TP-Link WA701) als auch bei den Antennen?

    Und vor allem nochmals vielen Dank
    Pratze
     
  5. MasterJM

    MasterJM Power-User

    Registriert seit:
    15. April 2005
    Beiträge:
    1.056
    Punkte für Erfolge:
    36
    Was ich empfehle? Ein schönes CAT LAN Kabel ;)

    Ansonsten testen, eingrenzen, Standortänderung beim Router kann schon einiges bringen.
    Teste es mit der Sendeleistung. Würd mich aber wundern, wenn es dadurch wirklich besser wird.
     
  6. Pratze

    Pratze Starter

    Registriert seit:
    16. Februar 2010
    Beiträge:
    3
    Punkte für Erfolge:
    1
    Ein LAN-Kabel wäre dann die letzte Alternative, nachdem ich vieles Kabellose ausprobiert haben möchte ;) (hier werden ganz andere Nerven gefordert als die momentan Jetzigen)

    Das führt natürlich dazu, dass zu allererst beim Flashen die Aktualisierung kurz vor Ende fehlgeschlagen ist und das GUI nicht mehr ansprechbar war, der Powerknopf blinkte ständig. Ich kann es mir im Nachhinein nur so erklären, dass ich den Router nicht resetet hatte. DHCP war disabled, es bestand zu dem Zeitpunkt auch eine Internetverbindung?!
    Können das Kriterien für einen Upgradabsturz sein? Wie waren eure Upgradevorgänge? Behaltet ihr grundsätzlich alle bisherigen Systemeinstellungen weiterhin vor? Trennt ihr die Internetverbindung? Resetet? Hatte den Firefox verwendet! Meinte gelesen zu haben, dass beim Flashen von DD-WRT Versionen hierbei abzuraten ist, stattdessen den IE benutzen. Tomato genauso?

    Zum Glück konnte ich nach etwas Recherche dann doch noch die Version 1.23 draufspielen, das Netzwerk funktioniert soweit wieder gut. Hatte zuerst Afterburner eingestellt und mw-werte auf 66 erhöht. Der Empfänger im Erdgeschoss jedoch hatte sehr rumgezickt und sich immer wieder disconnected. Also Werte auf default gesetzt und die Antennen in dessen Richtung gesetzt. Die Verbindung ist zurzeit stabil, dennoch gibt es arge Geschwindigkeitseinbußen.

    Werde den USB Stick mal gegen PCI-Karte und verlängertes Antennenkabel tauschen.
     
  7. MasterJM

    MasterJM Power-User

    Registriert seit:
    15. April 2005
    Beiträge:
    1.056
    Punkte für Erfolge:
    36
    Ich resete gar nichts und ich trenne gar nichts.

    Ich verwende Tomato seit einigen Jahren nun,
    download, entapcken, bin file hochladen, fertig.
    Bei einem Upgrade hat der Router mal die Config verschlammt.

    Sonst gabs noch nie Probleme, Firefox DHCP läuft, Internet läuft während flash.


    DD-WRT kommt mir nicht auf meinen 54GL, ich hasse diese FW.
     
  8. Buchenhunter

    Buchenhunter Gelegenheits-User

    Registriert seit:
    4. März 2010
    Beiträge:
    17
    Punkte für Erfolge:
    1
    Einen zweiten WTR54GL kaufen und den ein Geschoss tiefer stellen und dann WDS konfigurieren. Der Empfänger wird dann Client im WDS.
    Sendeleistung Drosseln und Antennen mit höherem Antennengewinn drauf! Warum ? Datenfunk läuft Bidirektional. Wenn du auf einer Seite die Sendeleistung erhöhst (Router) dann musst du das auch auf der anderen Seite (Erdgeschoss) tun!!
    Wenn zwei Personen 100 Meter auseinander stehen reicht es nicht wenn nur einer ein Megaphon hat!
    Bei Antennen mit Gewinn ist das anders. Antennengewinn hat man nicht nur beim Senden, sondern auch beim Empfang!!

    Achja, ich habe 3 Liknksys mit DDWRT im WDS laufen um 3 Etagen des Hauses zu befeuern (Muss auch nur 3MBit DSL verteilen :D ). Bei mir käme niemals OpenTomato drauf! Geschmackssache