Gelöst Linksys LRT214 VPN hinter Fritzbox

Dieses Thema im Forum "Linksys" wurde erstellt von Michael_PSI, 28. September 2019.

  1. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    Hallo, ich bin neu hier und benötige Hilfe bei der Einrichtung eines VPN. Es sollen ein Büro und eine Zweigstelle einer kleinen Firma per VPN miteinander verbunden werden, damit die Zweigstelle auf die Freigaben im Büro zugreifen kann.
    Hierfür habe ich zwei Linksys LRT214 gekauft und bereits soweit an den Standorten installiert, dass die lokalen Netzwerke über diese Router und die vorgeschalteten Fritten ins Internet können. Die Fritten bekommen vom Provider jeweils eine statische IP, die ich auch anpingen kann. Leider bekomme ich das VPN nicht zum Laufen. Vermutlich muss ich die statische IP des Providers noch irgendwo berücksichtigen. Hat Jemand in diesem Forum eine hilfreiche Idee? Im angehängten Bild habe ich meine Konfiguration mal dargestellt. Vielen Dank.
     

    Anhänge:

  2. RTBH

    RTBH Gelegenheits-User

    Registriert seit:
    19. März 2019
    Beiträge:
    12
    Punkte für Erfolge:
    3
    Hi,

    was spricht denn dagegen das VPN auf den FritzBoxen zu terminieren?
    gruß RTBH
     
  3. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    Ein Vpn auf der Fritz Box funktioniert zwar und reicht für RDP. In meinem Fall soll aber ein Programm auf die Freigaben zugreifen und dass packen die CPUs der Fritten nicht.
     
  4. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.057
    Punkte für Erfolge:
    120
    Hi,

    willkommen im Forum.

    Auf welcher Basis willst du den VPN-Tunnel aufbauen: OpenSSL oder IPSec? Du solltest trotz "Exposed host" die entsprechenden VPN-Ports in der FB weiterleiten zum Linksys. Also bei OpenVPN UDP 1194, bei IPSec UDP 500 und 4500, Protokoll ESP. Wenn die IPSec-Verbindung über l2tp läuft, dann noch den UDP 1701.

    Was soll denn der "VPN-Gateway" sein?

    VG
     
    Michael_PSI hat sich bedankt.
  5. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    In meiner Laborumgebung hatte ich immer die IP des anderen Routers als GW eingetragen. In der echten Konfiguration soll der Router1 der Server sein und der Router2 der Client.
     
  6. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    IPSEC soll es sein - Ports habe ich weitergeleitet.
     
  7. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    CapFloor - Dein Hinweis auf die Ports war goldrichtig. Habe in beiden Fritzen die Ports frei gegeben und die feste IP des Providers jeweils als Gateway im Router - jetzt steht der Tunnel. Was jetzt noch nicht funktioniert, ist der Zugriff auf die Freigabe eines Rechners im entfernten Netzwerk. Ich wollte ein LW-Mapping auf \\123.456.789.2\freigabe machen. Geht aber nicht - ich kann den Rechner über den Tunnel auch nicht anpingen. Muss ich im Router noch etwas einstellen?
     
  8. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    CapFloor - Dein Hinweis auf die Ports war goldrichtig. Ich habe in beiden Fritten die Ports für den Router freigegeben und die Provider IPs jeweils als Gateway in den Router eingetragen - der Tunnel steht. Leider habe ich noch keinen Zugriff auf die Freigabe hinter dem Router, obwohl Netbios Broadcast aktiviert ist. Ich kann den Rechner nicht anpingen.
     
  9. RTBH

    RTBH Gelegenheits-User

    Registriert seit:
    19. März 2019
    Beiträge:
    12
    Punkte für Erfolge:
    3
    NAT Traversal anschalten könnte schon die Lösung sein.
     
    Michael_PSI hat sich bedankt.
  10. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    NAT Traversal ist aktiviert. Den Router kann ich anpingen und sogar sein Webinterface öffnen. Aber alles Andere, was sich hinter dem Router befindet, kann ich nicht anpingen. Sollte ich das lokale Netzwerk des Routers an die DMZ - Buchse hängen? Oder muss ich im Router noch irgendwelche Routen einstellen? Bin für jeden Hinweis dankbar.
     
  11. RTBH

    RTBH Gelegenheits-User

    Registriert seit:
    19. März 2019
    Beiträge:
    12
    Punkte für Erfolge:
    3
    Nur um das zu verstehen...
    du hats jetzt jeweil portforwarding (router2) 123.123.123.1 -> 192.168.29.254 und von (router1) 456.456.456.1 -> 192.168.29.253 gemacht ? Dann hast du auf router2 als vpn gw die 456.456.456.1 und auf router1 das vpn gw 123.123.123.1 eingetragen ?

    der tunnel ist damit established und du kommst von 192.168.20.100 zu 192.168.29.253 (icmp/http(s)) ? soweit richtig ?

    PS: Dein Netzvergabe ist dezent gesagt, Kreativ ;) in der Theorie spannst du eine Layer2 Domain via ipsec über 2 Standorte...
     
    Michael_PSI hat sich bedankt.
  12. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    Hallo RTBH, ja ich kann vom Computer hinter Router2 sogar die IP des Router1 in seinem lokalen Netzwerk anpingen 192.168.10.1 und erreiche auch sein Webinterface. Aber alle Geräte hinter dem Router z. B. 192.168.10.2 kann ich nicht anpingen oder öffnen.
     
  13. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.057
    Punkte für Erfolge:
    120
    Hi,

    funktioniert der Ping auch in die andere Richtung?

    VG
     
    Michael_PSI hat sich bedankt.
  14. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    #14 Michael_PSI, 29. September 2019
    Zuletzt bearbeitet: 29. September 2019
    Von der anderen Seite kann ich auch nur den Router auf der Gegenseite erreichen. Die PCs dahinter kann ich nicht anpingen.
    Ich habe jetzt auf den Fritten den Netbios Filter deaktiviert und noch einige Ports für SMB freigegeben. Keine Veränderung, ich kann immer nur den Router unter 192.168.10.1 erreichen. Ein Ping auf seine Wan1 Schnittstelle mit 192.168.29.253 geht ins Leere.
     
  15. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.057
    Punkte für Erfolge:
    120
    Hi,

    poste bitte die Konfiguration der Router jeweils mit "Local Group Setup" und "Remote Group Setup".

    VG
     
    Michael_PSI hat sich bedankt.
  16. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    #16 Michael_PSI, 29. September 2019
    Zuletzt bearbeitet: 29. September 2019
    Ging leider nicht anders - hängt als PDF hier dran
     

    Anhänge:

  17. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.057
    Punkte für Erfolge:
    120
    #17 CapFloor, 29. September 2019
    Zuletzt bearbeitet: 29. September 2019
    Hi,

    ok, allerdings muss mMn im "Local Group Setup" unter IP die WAN-IP der FB angegeben werden - also die festen IPs, die gekreuzt jeweils im "Remote Group Setup" angegeben sind.

    Außerdem solltest du doch die LAN-Subnetze der FBen, also aktuell beide 192.168.29.0/24, auf beiden Seite unterschiedlich setzen. Du kannst so auf keinen Fall remote auf dieses Subnetz von jeweils der andere Seite zugreifen...

    VG
     
    Michael_PSI hat sich bedankt.
  18. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    Okay Lan-Subnetze der Fritten habe ich unterschiedlich, Tunnel läuft.
    Wenn ich anstelle der IP vom Provider die jeweilige WAN-IP des entfernten Routers verwende, wird der Tunnel nicht aufgebaut.
     
  19. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.057
    Punkte für Erfolge:
    120
    Hi,
    Verstehe ich zwar nicht, aber das ist ja nicht relevant.
    Ist dein Problem damit gelöst?

    VG
     
    Michael_PSI hat sich bedankt.
  20. Michael_PSI

    Michael_PSI Gelegenheits-User

    Registriert seit:
    28. September 2019
    Beiträge:
    22
    Punkte für Erfolge:
    1
    Mein Problem ist soweit gelöst, dass ich jetzt das Laufwerkmapping hinbekommen habe. Dein Input hat hier doch geholfen - wobei der eigentliche Fehler, der den Zugriff auf die Freigabe verhindert hat, ein falscher Gateway auf dem Rechner war. Jetzt habe ich "nur" noch das Problem, dass die Geschwindigkeit nicht besonders ist. Das Laden des Programmes dauert ewig - da ging es fast mit dem Fritz-VPN schneller. Aber das muss ich wohl morgen untersuchen. Zunächst einmal vielen Dank.