2. VLAN-ID für Telefonie über Multi V-Lan

Dieses Thema im Forum "DrayTek (Vigor)" wurde erstellt von Born2Dive, 31. Dezember 2019.

  1. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Hallo,

    ich sitze jetzt schon seit 2 Tagen an meiner Telefonie und komme nicht weiter.

    Folgende Hardware läuft bei mir.

    1. Vigor 165 im Fullbridge Modus mit VLAN-ID 132 für einen Internetanschluss von Innogy. VDSL2.
    2. Unifi USG Router der auf DHCP am Vigor hängt. Dahinter Switche und WLAN AP´s.
    3. Fritzbox am Switch als reines Telefoniegerät mit DECT Telefone.

    Problem wie gebe ich dem Vigor ein 2. VLAN-ID 232 ein diese wird für die Telefonie bei Innogie aber dringend benötigt.

    In der Beschreibung des Vigors steht :Weiterhin unterstützt der Vigor 165 Multi-VLAN auf dem DSL-Port und ermöglicht so Tripple-Play Installationen.

    Vielleicht ist das ja der Schlüssel zum Erfolg.

    Danke im schonmal im voraus.
     
  2. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,

    schau dir mal die Einstellungen unter "Internet Access->Multi-PVC/VLAN" an. Dort kannst du ein weiteres WAN-Interface mit VID 232 konfigurieren und auch an einen der beiden Ethernet-Ports bridgen.

    Dieser Ethernet Port muss dann mit einem extra Kabel mit dem USG verbunden werden. Es kann auch sein, dass du die WAN-Verbindung mit VID 232 auf den selben Ethernet-Port bridgen kannst wie die PPPoE-Internet Verbindung. Dann müsste der Vigor die Verbindung allerdings auch mit VID 232 taggen. Versuche besser erst mal das Bridgen mit dem anderen Port des Vigor...

    An der USG solltest du dann per DHCP auf dem zweiten Anschlussport zum Vigor eine IP-Adresse bekommen, über die die Anmeldung der Telefonie funktioniert - so jedenfalls meine Theorie:D.

    VG
     
  3. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Hi,

    frohes Neues erstmal.

    Ok. habe das jetzt erstmal so versucht. Bekomme aber wohl keine Verbindung. Über das USG bzw. Fritzbox Telefonie funktioniert immer noch nicht.
     

    Anhänge:

  4. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,

    im Screenshot 15 sollte "Offene Port-basierte Bridge-Verbindung für diesen Kanal" angehakt sein und darunter ein Haken bei "P2". Ich weiss nicht, über welchen Port des Draytek-Modems die PPPoE Internetverbindung geleitet wird. Ist das über Port 1?

    Es kann noch sein, dass der Draytek diese zweite Verbindung mit einem VLAN Tag in Richtung der USG versieht (oder präziser: das VLAN Tag nicht entfernt). Dann muss der Port an der USG ebenfalls mit der VID 232 umgehen können, also PVID=232 und Port ist Mitglied im VLAN 232.

    VG
     
  5. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Hi,


    ich hoffe ich verstehe das Ganze. Bitte um etwas Nachsicht. Musste mich noch nie so dermaßen damit auseinandersetzen.

    Also, das USG Lan1/Wan1 hängt am Draytek über P1.


    Vlan vergabe nur im Draytek. Der USG wählt sich nur über DHCP ein also ohne Benutzername und Passwort.
     
  6. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,
    1. Wie, d.h. über welche Ports, ist der Draytek (ohne Telefonie) mit dem USG verbunden?
    2. Hast du beim Draytek die Bridge zwischen dem zweiten, virtuellen WAN-Port für die Telefonie (VLAN 232) und dem Ethernet-Port 2 (P2) hergestellt?
    3. Wenn die WAN-Ports für Internet und für Telefonie im Draytek auf den gleichen Ethernet-Port gebridgt sind, muss in dem USG das virtuelle Interface für die Telefonie mit VID 232 getaggt werden. In dem USG Screenshot muss dann also "VLAN ID benutzen" angehakt und der Wert 232 eingetragen sein.
    Es müssen für die Konnektivität des Telefonie-Zugangs keine Zugangsdaten eingegeben werden, weder beim Draytek noch im USG. Im USG muss auf dem Telefonie-Port "DHCP verwenden" eingestellt sein.

    Wenn das erstmal bis dahin funktionieren würde, kann man sich danach um die Telefoniekonfiguration in der FB kümmern.

    VG
     
  7. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Hi,

    1. Port 1 ist mit dem WAN der USG verbunden
    2. Ich stelle mal ein Bild ein. Hoffe das ich das so richtig eingestellt habe. Nur wie kann ich prüfen ob das auch wirklich funktioniert.
    3. VLAN ID 232 habe ich auf der Fritzbox eingestellt. Diese ist im selben internen Netz angeschlossen.

    Internet läuft ohne Probleme. Nur bei der Registrieung der Telefoniedaten komme ich nicht weiter.
    Mache nochmal ein paar Screenshots vielleicht hilft das weiter.

    Gruß
     
  8. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Hier noch die Screenshoots
     

    Anhänge:

  9. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Und von dem USG
     

    Anhänge:

  10. Thorsten_Z

    Thorsten_Z Starter

    Registriert seit:
    6. Januar 2020
    Beiträge:
    1
    Punkte für Erfolge:
    1
    #10 Thorsten_Z, 6. Januar 2020
    Zuletzt von einem Moderator bearbeitet: 6. Januar 2020
    Hi,
    Vlt. hilft dir dieses Video weiter. [Moderator: Video entfernt, kein Bezug zum Problem] Da geht es zwar ums Fax, .. aber möglich ist ja alles.

    Gruß
     
  11. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    [Moderator: Full Quote entfernt]

    Das hatte ich jahrelang so laufen. Allerdings bei der Telekom wo Internet und Telefonie über V-LAN ID 7 liefen. Habe die ID einfach im USG bei der Einwahl vergeben und alles lief so wie oben im Video konfiguriert.
    Jetzt der neue FTTC Anschluß von Innogy verlangt die VLAN ID 132 für Internet und VLAN ID 232 für die Telefonie. Und genau hier komme ich nicht weiter.
    Gebe ich im Vigor die 132 oder im USG läuft halt nur das Internet. Für die Telefonie kann ich in der Fritzbox die die ID 232 einstellen. Nur so bekomme ich die Rufnumnern nicht registriert.
    Damit es jetzt überhaupt funktioniert habe ich die Fritzbox vorne zur Einwahl und Telefonie und über Lan1 am WAN1 der USG laufen.
    Ob das jetzt schlecht ist wegen doppeltem NAT? Mhhh bisher kann ich keine Nachteile feststellen.
     
  12. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,
    dein Vigor Modem nutzt du jetzt gar nicht mehr?
    Du kannst ja das NAT in der USG bestimmt abschalten. Dann brauchst du nur noch Routen für die Subnetze hinter dem USG in der FB konfigurieren und schon funktioniert es ohne Doppel-NAT.

    VG
     
  13. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Eigentlich ist ja alles hinter dem USG. Kamera-Lan, Privat, Gast, Haussteuererung.......
    Ales mit eigenem Adressbereich und VLAN.
    Möchte schon den Vigor wieder als reines Modem und die Fritzbox als reines Telefoniegerät nutzen.
     
  14. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,

    ganz ehrlich? Das verstehe ich nicht. Mit dem Vigor wird die Netzwerkstruktur komplizierter und die FB muss sowieso fürs Telefon bleiben. Das NAT kannst du bestimmt in dem USG abschalten.

    VG
     
  15. Willforce

    Willforce Stammgast

    Registriert seit:
    10. Oktober 2019
    Beiträge:
    60
    Punkte für Erfolge:
    8
    Wenn der Vigor im Fullbrigdge läuft spielen die Router Funktionen keine Rolle, da sie keine Auswirkung haben.
    Lediglich die VLAN Tags, welche in Werkseinstellungen auf 7 gesetzt sind, müssen angepasst werden sofern notwendig.
    Der 165er ist also ein reines DSL Modem...
    Den Rest müssen die Geräte dahinter verwalten.
     
  16. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,
    das war aber nicht der Hintergrund für meinen letzten Beitrag. Der bezog sich auf die Ist-Situation - ganz ohne den Vigor -, die ich für effektiv halte.

    VG
     
  17. CapFloor

    CapFloor Moderator

    Registriert seit:
    9. August 2010
    Beiträge:
    3.474
    Punkte für Erfolge:
    160
    Hi,

    im Screenshot (32) darf kein Haken bei "WAN-Schnittstelle für diesen Kanal öffnen" gesetzt sein, sondern bei "Offene Port-basierte Bridge-Verbindung für diesen Kanal" und weitere Haken bei "P2".

    Kennst du dich irgendwie mit VLANs aus? Es geht darum, dass die für die Telefonie benötigte Verbindung mit VLAN-ID 232 am Port der Vigor (P2) ausgeleitet wird und dann auf der USG Seite mit einer entsprechenden VLAN-Konfiguration, ebenfalls VLAN-ID 232, empfangen wird.

    Vielleicht hilft dir dieses Zielbild, die Konfiguration zum Laufen zu bringen. Meiner Meinung nach müsste das so wie von mir beschrieben funktionieren. Nur musst du eben auf der USG Seite die passende VLAN-Konfiguration für VLAN-ID 232 durchführen.

    VG
     
  18. Bachel

    Bachel Starter

    Registriert seit:
    28. März 2020
    Beiträge:
    3
    Punkte für Erfolge:
    1
    Hi,
    habe die gleiche Problematik zu lösen.
    @Borne2Dive: bist Du mit diesem Lösungsansatz weitergekommen?
    Danke im Voraus für Deine Antwort!
     
  19. Born2Dive

    Born2Dive Gelegenheits-User

    Registriert seit:
    24. Februar 2008
    Beiträge:
    11
    Punkte für Erfolge:
    1
    Hallo Bachel,

    nein habe es leider nicht hinbekommen. Funktionierte bei mir nur wenn ich die Fritzbox als Modem vor dem USG gesetzt habe. Die FB stellt die Internetverbindung und die Telefonie her. USG übernimmt dann das routing und die Firewall. So lief es testweise 2 Wochen bis ich die faxen dicke hatte. Mehrmals täglich brach die Internetverbindung zusammen was beim Streamen von Sport und Netflix dann echt nervte.

    Aktuell habe ich jetzt wieder die Fritzbox für die Telefonie hinter dem USG mit einem anderen ip-telefonie Anbieter am laufen. Das funktioniert jetzt endlich.

    Solltest Du ein Lösungsansatz finden wäre es nett wenn Du mal bescheid geben könntest.

    Gruß Christian
     
  20. Bachel

    Bachel Starter

    Registriert seit:
    28. März 2020
    Beiträge:
    3
    Punkte für Erfolge:
    1
    Danke für die Rückmeldung Christian, I will try my very best!
    Gruß Bernhard