Cisco 1812

Dieses Thema im Forum "Cisco" wurde erstellt von lernfaehig, 10. März 2010.

  1. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    Hallo Forum,

    ich bin ein ziemlicher Cisco Laie.
    Habe mal einen 16xx Router mit zwei Ethernet Schnittstellen zum laufen gebracht und einige ACLs eingetragen.
    Das wars aber dann schon mit meinen Cisco/IOS Kenntnissen.

    Jetzt habe ich die Möglichkeit günstig an einen 1812 Router zu kommen.
    Ich kann mir eine ganze Menge unter DHCP, NAT, VPN etc. vorstellen.

    Die erste Frage, die ich habe:
    der Router hat ja zwei FE ports (fe0 und 1) plus 8 FE switch Ports (Fe2-10).
    Wie muss ich mir die Kombination der 10 Ports vorstellen.
    Kann ich "nur" zwei Netze (fe0 und 1) anbinden und einem Netz (wahlweise?) dann den Switch zuordnen?
    Funktionieren die 8 Ports nur wie ein externer Switch oder könnte ich die Ports einzeln Fe0 und Fe1 zuweisen?
    Könnte ich mit den Ports Fe2-10 auch weitere Netze anbinden?

    Für eine ausführliche Antwort wäre ich sehr dankbar.

    Bin ja lernfähig

    :oops:
     
  2. lltodoll

    lltodoll Starter

    Registriert seit:
    4. März 2010
    Beiträge:
    9
    Punkte für Erfolge:
    1
    Hi,
    also nach ein bisschen googlen, findet man doch schon einiges ;-).
    Ich bin zwar auch Anfänger aber ich versuchs mal dir zu erklären:

    Code:
    Cisco 1812 
     Fast Ethernet LANs 
     SWITCH and FE9-FE6 (top), FE x and FE5-FE2 (bottom) 
     
    Fast Ethernet WANs 
     FE0-FE1 
     
    Wireless LAN 
     LEFT, RIGHT/PRIMARY 
     
    BRI 
     ISDN S/T 
     
    USB 
     1-0 
     
    
    Jeder diese FastEthernet Schnittstelle kannst du Vlans zuorden etc, also frei konfiguirbar, nicht wie ne ganz normales "billiges" Switch was nur im Trasparenz Mode arbeitet.
    Wie man sieht fungieren die Ports FE0-FE1 als Fast Ethernet WAN und die Ports FE2-FE9 als Fast Ethernet LAN.

    PS: Was meinst du mit zwei Netzen ?
     
  3. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    Hallo,

    vielen Dank, hilft mir schon etwas weiter.
    Mit zwei Netzen meine ich, das ich z.B. mit dem 1600 Router jeweils einen Switch an den Fe Ports hatte und damit zwei Netze adressieren konnte.

    Das könnte ja jetzt auch wieder mit Fe0 und Fe1. Da ist jetzt meine Frage anstatt einen externen Switch zu nehmen, könnte ich ja Fe2-Fe9 als Switchports nutzen. Wie weise ich ich aber dann dem Router Port zu?

    Wenn ich das aber jetzt richtig verstanden habe, könnte ich zB. Fe0 und Fe2-Fe5 als Vlan1 und Fe1 und Fe6-Fe9 als VLAN2 konfigurieren???
    Bin ich dann bei der IP-Adrssenvergabe ganz frei oder müssen alle Ports in einem Netz liegen?
    Wer ist jeweils im VLAN mein Standardgatewey?

    Wie wäre das aber mit NAT, wenn ein Port der NAT Port sein soll?

    Ich merke jetzt, um mehr ich mich da hineinvertiefe, um so mehr Fragen tauchen auf.

    Grüße

    der Lernfaehige
     
  4. Buchenhunter

    Buchenhunter Gelegenheits-User

    Registriert seit:
    4. März 2010
    Beiträge:
    17
    Punkte für Erfolge:
    1
    Wieso willst du VLAN´s erstellen, wenn du 2 unterschiedliche Netzwerke hast?
    Warum NAT?
    Erstell mal einen Netzplan und dann kann man über die Konfiguration Sprechen.
    Einfache Zeichnung erstellen, welche Netzwerke wohin und dann kommt der Rest.
    Kannst auch mal ein "sh run" von deinem alten Router Posten.
     
  5. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    Hallo,

    ich will mir den Router, für das Einarbeiten in das Thema Cisco anschaffen (gesten zweimal überboten worden bei ebay). Es gibt kein bestimmtes Netz wofür er eingesetzt werden soll.
    Ich möchte nur alle Möglichkeiten verstehen, wofür man ihn einsetzen kann.
    Daraus wollte ich mir dann eine Konfigurationsübersicht erstellen.

    Dort, wo ich die Möglichkeit habe, ihn zu testen, gibt es schon einen Router von der Telekom der NAT für ein 10. ner Netz macht. Dieser darf nicht umkonfiguriert werden und es läuft scheinbar auch kein Routing-Protokoll darauf.
    Daher müsste ich, um eine Internetverbindung zu bekommen, Nat zum Telekom-Router machen, damit er meinen Router auch als 10. ner Netz Station sieht.

    Bei den anderen Fragen ging es um die Konfigurationsmöglichkeiten.

    Wäre also immer noch um einige Antworten dankbar.

    Grüße

    der Lernfähige
     
  6. Buchenhunter

    Buchenhunter Gelegenheits-User

    Registriert seit:
    4. März 2010
    Beiträge:
    17
    Punkte für Erfolge:
    1
    Der 1811 ist ein schöner Router zum erlernen von Cisco.

    Es würde reichen, wenn du einem Fe eine IP im 10er Netz gibst und den anderen Fe auf Trunking dot1Q setzt. Daran könntest du alle VLAN´s des SwitchPorts (Verkablung notwendig) auflaufen lassen und statisch ins 10er Netz Routen.
    Kannst aber auch NAT machen.
    ACL´s kannst du auf beiden Fe inbound/outbound machen, wie du es gerne möchtest.
    Wichtig ist ein "no cdp run", damit er nicht so geschwätzig mit dem "magenta"-Router ist und eine ACL das kein Telnet/SSH, sofern konfiguriert vom 10er Netz aus möglich ist.
    Zudem würde ich keine dynamischen Routingprotokolle verwenden.
     
  7. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    Hallo,

    meintest Du 1811 oder 12?
    Soweit ich verstanden habe, ist der 1811 ohne WLAN oder?

    "Es würde reichen, wenn du einem Fe eine IP im 10er Netz gibst und den anderen Fe auf Trunking dot1Q setzt".
    Ich versuche mal zu übersetzen:
    z.B. Fe0 als 10er Netz Richtung Telekom Router konfigurieren (bekomme ich hin)
    Fe1-Fe9 auf Trunking dot1Q (wie geht das?), damit gehören alle an Fe1-9 angeschlossenen Rechner zum 10er Netz und haben als Standard Gateway die IP von Fe0, richtig?

    Das wäre schon mal eine elegante Lösung.

    Wie sähe aber folgendes aus?
    Ich will zwei kleine Netze mit jeweils maximal 4 Clients haben z.B. 192.168.10.0 und 192.168.20.0. Das müsste ich doch mit Fe2-5 als VLAN1 und Fe6-9 als VLAN2 machen können, oder?
    Was bekommen die Ports für IP-Adressen (eigentlich pro VLAN nur eine) und wie kann ich jetzt die VLANs mit anderen Netzen bzw. auch untereinander koppeln?

    Dann noch das ganze WLAN-Thema, das will ich mir aber für später aufheben.

    Als letztes noch die ISDN-Schnittstelle. BRI0 plus BRI0:1 und BRI0:2 sind das die drei ISDN-Kanäle (D,B1,B2)?

    Danke für jede Antwort
     
  8. Buchenhunter

    Buchenhunter Gelegenheits-User

    Registriert seit:
    4. März 2010
    Beiträge:
    17
    Punkte für Erfolge:
    1
    Jep, der 1812 ist mit WLAN. War eben mal im Testlab und hab was für Morgen prüfen müssen. Da hab ich mal 10 Minuten gespielt und eine Minimal-Config entworfen.

    So könnte deine Config aussehen.
    Hab bis auf VPN mal alles relisiert.
    Hab jedoch aus Zeitgründen RIP statt Static-Routing benutzt ;-)
    Auch die Inbound ACL vom 10er Netz für Telnet und SSH fehlt,
    ist aber nur Kosmetik.....


    BITTESCHÖN!!!


    ________________________________________________________________
    !nehmen wir mal an
    !interface fa0/0 und 0/1 router-ports
    !interface fa1/0 bis fa1/7 switchports
    !fa 0/0 und fa1/0 sind physikalisch verbunden
    !DHCP fuer beide vlans an
    !NAT nach 10.10.10.2
    !das gateway im 10er netz ist 10.10.10.1
    !
    !
    !
    !
    !
    !
    no ip domain-lookup
    !
    no cdp run
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.254 255.255.255.0
    ip nat inside
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.20.254 255.255.255.0
    ip nat inside
    !
    interface FastEthernet0/1
    ip address 10.10.10.2 255.0.0.0
    ip nat outside
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router rip
    version 2
    network 10.0.0.0
    network 192.168.10.0
    network 192.168.20.0
    !
    ip nat pool eins 10.10.10.2 10.10.10.2 netmask 255.0.0.0
    ip nat inside source list 10 pool eins overload
    ip classless
    !
    !
    access-list 10 permit 192.168.10.0 0.0.0.255
    access-list 10 permit 192.168.20.0 0.0.0.255
    !
    ip dhcp excluded-address 192.168.10.254
    ip dhcp excluded-address 192.168.20.254
    !
    ip dhcp pool test
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.254
    dns-server 192.168.10.254
    ip dhcp pool test1
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.254
    dns-server 192.168.20.254

    interface FastEthernet1/0
    switchport mode trunk
    !
    interface FastEthernet1/1
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet1/2
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet1/3
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet1/4
    switchport access vlan 10
    switchport mode access
    !
    interface FastEthernet1/5
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet1/6
    switchport access vlan 20
    switchport mode access
    !
    interface FastEthernet1/7
    switchport access vlan 20
    switchport mode access
    _____________________________________________
    Ich weiss nicht, ob die Switchports VPN (IP-Sec bzw. GRE) beherrschen.

    BRI beeinhaltet ISDN. 2B-Kanäle und ein D-Kanal für die Signalisierung. Das gehört dann schon zur "Fortgeschrittenen Disziplin" im Cisco-IOS.
    Nimm es mir nicht übel, ich halte dich keineswegs für dumm, aber du musst erst die Netzwerkseite beherrschen, bevor du in die Weitverkehsverbindungen einsteigst. Bis dahin ist es noch ein weiter Weg. Ich weiss wovon ich Spreche :eek:
     
  9. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    Oh, oh, oh

    erstmal vielen Dank.
    Bevor ich aber konfiguriere, muss ich gestehen, ich verstehe max. 50% von der Konfiguration.
    Daher lieber erst mal schlau machen, bevor ich was konfiguriere, wovon ich keine Ahnung habe.
    Ich versuche mal das nicht verstehen zu beschreiben.

    Das Konzept an sich ist klar.
    Bei den Interface Kommandos 2 und 3 für fa0 hört es schon auf.
    Hat was mit VLAN zu tun, VLAN 10 und 20???, was bedeuten die IP-Adressen dazu?
    Fa0/1 bekommt die Adresse 10.10.10.2 Richtung Telekom Router
    dann RIP aktivieren
    bei Nat pool hätte ich den internen Pool definiert,
    access-list an sich klar
    dhcp excluded ok
    dhcp pool ok

    fa1/0 wird trunk port für alle danach konfigurierten vlan ports

    na geht ja noch

    fehlt da nicht noch die Gateway zuordnung (10.10.10.1)?

    Danke
     
  10. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    kann es sein, dass der 1812 kein n/n zulässt.
    Er gibt für das shlash-Zeichen immer eine Fehlermeldung aus.

    Wenn ich ................. fa0 ? eingebe,
    gibt er nur , comma und - hyphen als Antwort.
     
  11. lernfaehig

    lernfaehig Starter

    Registriert seit:
    10. März 2010
    Beiträge:
    7
    Punkte für Erfolge:
    1
    Hurra, es funktioniert

    Man muss bei int range z.B. fa2 - 5 angeben
    Zuordnung VLAN1
    und fa6 - 9 für vlan2.

    Wofür man jetzt evtl. noch fa1 verwenden kann, keine Ahnung


    Das war keine ganz leichte Geburt
     
  12. Buchenhunter

    Buchenhunter Gelegenheits-User

    Registriert seit:
    4. März 2010
    Beiträge:
    17
    Punkte für Erfolge:
    1
    Freut mich, dass es geklappt hat.
    Stimmt, die Default-Route zu deinem Gateway fehlt noch.
    Wie gesagt, viele Wege führen nach Rom. Das war nur einer.
    Ein VLAN sollte immer eine IP haben, damit du ein einheitliches Gateway hast um aus dem VLAN zu routen!
    Die Zeile "FastEthernet 0/0:20 beeinhaltet ein virtuelles Subinterface des Fa 0/0. Nach dem Dot1Q weiss der Cisco dass es
    es auf Trunking gesetzt ist.
    Viel Spass noch beim "CISCO-Speeching"

    Buchenhunter