876W NAT/Routing Problem...

Dieses Thema im Forum "Cisco" wurde erstellt von Waschbuesch, 20. März 2010.

  1. Waschbuesch

    Waschbuesch Starter

    Registriert seit:
    20. März 2010
    Beiträge:
    2
    Punkte für Erfolge:
    1
    Hallo,

    Ich habe mir mit einem 876W ein Netzwerk mit zwei VLANs eingerichtet.
    VLAN 1 (192.168.1.1/24) bedient WLAN und die Fast Ethernet Ports 1-3 mit DHCP (über ein Bridging Interface BVI 1)
    An VLAN 2 (192.168.2.1) hängt mein Email / Web / etc. Server.

    Ich habe eine feste IP Adresse mit passendem Reverse lookup, etc. und da per NAT die entsprechenden Ports auf den Server verweisen, kann ich von aussen auch prima auf alles zugreifen.

    ABER: Wenn ich von innerhalb des Netzes (VLAN 1) versuche per SSH oder Web oder IMAP oder so auf den Server zuzugreifen, dann antwortet anstatt dessen immer der Router!? Und das ganz gleich, ob ich versuche den FQDN zu nutzen oder die öffentliche IP?

    Hat jemand nen Tipp, woran das liegen könnte?

    M.W.
     
  2. Buchenhunter

    Buchenhunter Gelegenheits-User

    Registriert seit:
    4. März 2010
    Beiträge:
    17
    Punkte für Erfolge:
    1
    poste mal die running-config!!
    sonst kann man nur raten.
    lass bitte den teil mit dem enable secret weg. interessiert keinen :D
     
  3. Waschbuesch

    Waschbuesch Starter

    Registriert seit:
    20. März 2010
    Beiträge:
    2
    Punkte für Erfolge:
    1
    So... Danke erstmal - ich hab hier jetzt mal die aktuelle Konfig angefügt (und die Passworte maskiert)... Sind vermutlich eine Menge Dinge nicht optimal - ich hab die Gerundkonfig mit dem auf dem Router vorhandenen Webtool erstellt und dann von Hand weitergemacht so gut ich konnte - bin (offensichtlich) kein Experte. ;-)

    Obwohl ich die IP Adresse bei Kommunikation mit dem Provider beziehe, ist es doch eine feste Adresse.


    Using 5548 out of 131072 bytes
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname cisco
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 51200
    logging console critical
    enable secret 5 <mypassword>
    !
    no aaa new-model
    clock timezone PCTime 1
    clock summer-time PCTime date Mar 30 2003 2:00 Oct 26 2003 3:00
    !
    crypto pki trustpoint TP-self-signed-910149805
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-910149805
    revocation-check none
    rsakeypair TP-self-signed-910149805
    !
    !
    crypto pki certificate chain TP-self-signed-910149805
    certificate self-signed 01 nvram:IOS-Self-Sig#1D.cer
    dot11 syslog
    !
    dot11 ssid Rhino
    vlan 1
    authentication open
    authentication key-management wpa
    mbssid guest-mode
    wpa-psk ascii 7 <my-psk>
    !
    no ip source-route
    ip dhcp excluded-address 192.168.1.1
    !
    ip dhcp pool ccp-pool1
    import all
    network 192.168.1.0 255.255.255.0
    dns-server 212.18.0.5 212.18.3.5
    default-router 192.168.1.1
    !
    !
    ip cef
    no ip bootp server
    ip domain name waschbuesch.de
    ip name-server 212.18.0.5
    ip name-server 212.18.3.5
    !
    !
    !
    !
    username admin privilege 15 secret 5 <mysecret>
    !
    !
    !
    archive
    log config
    hidekeys
    !
    !
    ip tcp synwait-time 10
    ip ssh time-out 60
    ip ssh authentication-retries 2
    !
    bridge irb
    !
    !
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    encapsulation hdlc
    shutdown
    !
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
    description $FW_OUTSIDE$$ES_WAN$
    ip flow ingress
    pvc 1/32
    pppoe-client dial-pool-number 1
    !
    !
    interface FastEthernet0
    switchport access vlan 2
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    !
    encryption vlan 1 mode ciphers aes-ccm
    !
    broadcast-key vlan 1 change 30
    !
    !
    ssid Rhino
    !
    mbssid
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    ip flow ingress
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    bridge-group 1
    !
    interface Vlan2
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    interface Dialer0
    mtu 1492
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap pap callin
    ppp chap hostname <hostname>
    ppp chap password 7 <password>
    ppp pap sent-username <username>
    !
    interface BVI1
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    !
    ip nat inside source static tcp 192.168.2.2 22 interface Dialer0 22
    ip nat inside source static tcp 192.168.2.2 25 interface Dialer0 25
    ip nat inside source static tcp 192.168.2.2 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.2.2 443 interface Dialer0 443
    ip nat inside source static tcp 192.168.2.2 587 interface Dialer0 587
    ip nat inside source static tcp 192.168.2.2 993 interface Dialer0 993
    ip nat inside source list 1 interface Dialer0 overload
    !
    logging trap debugging
    access-list 1 remark CCP_ACL Category=2
    access-list 1 permit 192.168.2.0 0.0.0.255
    access-list 1 permit 192.168.1.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run

    !
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end