Router per Batch auf vorhandene HDD prüfen

Dieses Thema im Forum "AVM (Fritz)" wurde erstellt von icepick1661, 18. Februar 2018.

  1. icepick1661

    icepick1661 Starter

    Registriert seit:
    18. Februar 2018
    Beiträge:
    2
    Punkte für Erfolge:
    3
    Hallo,
    ich möchte Daten auf eine externe HDD am Router sichern. Dazu habe ich eine Batch geschrieben, die das auch bewerkstelligt: mit einem Ping wird geprüft, ob das WLAN geschaltet ist und mit "net use" werden die Partitionen verbunden.

    Das Problem: die Festplatte hängt nicht immer am Router. Der net use-Befehl führt dann zu einer Fehlermeldung und die Ausführung hängt an dieser Stelle. Da die Batch im Hintergrund automatisch gestartet werden soll, möchtee ich nun, dass zwischen Ping und "net use" zunächst geprüft wird, ob die HDD überhaupt angeschlossen ist.

    Gibt es also eine Möglichkeit, per Batch zu prüfen, ob eine Festplatte am Router hängt? Bitte sagt mir auch gerne, wenn das nicht möglich ist.

    Danke für Eure Hilfe!
     
  2. icepick1661

    icepick1661 Starter

    Registriert seit:
    18. Februar 2018
    Beiträge:
    2
    Punkte für Erfolge:
    3
    Hallo,

    die Lösung habe ich selbst gefunden, ich hatte ziemlich Tomaten auf den Augen, Matsch im Hirn und was es sonst so alles gibt: man fängt den Fehler natürlich einfach ab. In die Zeile unter der "net use"-Anmeldung setzt man:
    if errorlevel 1 goto :[andere Sektion im Batch oder Ende]
     
    frank.td hat sich bedankt.