IPv6-Adresse von myfritz ist falsch (?)

Dieses Thema im Forum "AVM (Fritz)" wurde erstellt von landwehrkanal, 25. Februar 2018.

Schlagworte:
  1. landwehrkanal

    landwehrkanal Starter

    Registriert seit:
    21. November 2017
    Beiträge:
    4
    Punkte für Erfolge:
    1
    Hi!

    habe seit einem Monat wieder echtes Dualstack und kann meine nextcloud auf dem raspi jetzt endlich von außen per smartphone etc. erreichen. Zu Backup-Zwecken möchte ich gerne per Skript per IPv6 auf einen anderen Server zugreifen (weil es dort kein echtes Dualstack gibt). Zum testen probiere ich das ganze aktuell im Heimnetz aus und verzweifle daran, dass die myfritz-Freigabe auf eine falsche IPv6-Adresse weiterleitet.

    Nochmal im Detail:

    a) 2 raspis in einem Netzwerk hinter einer Fritzbox 7490. Untereinander (ping -6 hostname_server-a) finden sie sich problemlos mit ihren IPv6-Adressen. Kann mich natürlich auch per ssh am jeweils anderen anmelden.

    b) per myfritz Freigabe port 22 (IPv4 und IPv6) für einen der beiden raspis erstellt um von extern per ssh und IPv6 zugreifen zu können

    c) die angebenene IPv6-Adresse der myfritz-Freigabe besteht aus dem Präfix, das die Fritzbox bekommt und der IPv6-Interface-ID des einen raspis. Macht ja auch Sinn...leider kann ich unter dieser kein Gerät erreichen (ping -6 [IPv6-Adresse] führt zu "address unreachable"). Andererseits gibt mir die Fritzbox unter -Heimnetz-Details eine andere IPv6-Adresse (beginnt ebenso mit dem 2003:etc Präfix des Routers, hat aber einen anderen 4x4 Block am Ende) an, die ich per ping -6 erreichen kann.

    d) Die IPv6-Interface ID, die die Fritzbox vom raspi hat, stimmt. Habe per "ifconfig" auf dem raspi nachgesehen, dort taucht die erreichbare IPv6-Adresse UND die IPv6-Interface ID auf.

    e) Hab schon verschiedene Einstellungen bzgl. IPv6/DHCPv6 etc. ausprobiert, aber noch keine Lösung gefunden. Hat jemand eine Idee woran es liegt dass myfritz eine "falsche" IPv6-Adresse ausliest/weitergibt?
     
  2. MPW

    MPW Starter

    Registriert seit:
    22. Dezember 2005
    Beiträge:
    3
    Punkte für Erfolge:
    1
    Moin,

    ich habe hier dasselbe Problem mit einem Ubuntu 16.04 (normales x86). Wenn man die Interface-ID in der FritzBox korrigiert, funktioniert es. Sonst nicht.

    Scheint ein Problem in der Kommunikation zwischen Linux und den Fritzboxen zu sein.

    Grüße
    Matthias