allneta + winxp automatisch online ?

Dieses Thema im Forum "Allnet" wurde erstellt von Lars12, 18. August 2002.

  1. Lars12

    Lars12 Starter

    Registriert seit:
    8. August 2002
    Beiträge:
    2
    Punkte für Erfolge:
    1
    Hi Leute.
    Ich habe folgendes Problem: Wenn ich den winxp Rechner anschalte geht der Router gleich erstmal online.Sieht man nur an der leiste von dem DSL Speedmanager. Die Nutzungszeiten habe ich dann bei der Abfrage der Nutungsdaten festgestellt.
    Bei dem win 98 Rechner ict das nicht so ! Muß ich bei win xp noch irgendetwas einstellen ? Ich habe alle Programme deaktiviert die automatisch nach dem Computerstart online gehen wollen. Was soll ich sonst noch machen ????
     
  2. SkyJumper2002

    SkyJumper2002 Super-User

    Registriert seit:
    6. September 2001
    Beiträge:
    3.884
    Punkte für Erfolge:
    76
    installier Dir ZoneAlarm, und dann wirst du den Übeltäter schon finden :idee:
     
  3. heavybyte

    heavybyte Super-User

    Registriert seit:
    27. Dezember 2001
    Beiträge:
    2.484
    Punkte für Erfolge:
    56
    hi leutz,
    dieses thema wurde schon x-mal angesprochen aber es kamen nie befriedigende antworten dabei heraus.
    meine persönliche meinung dazu ist (habe viel herumexperimentiert):
    ein router baut immer dann eine verbindung in das andere netz auf (WAN) wenn im eigenen netz eine adresse aufgelöst werden soll, die da nicht existent ist, z.B. gibst du im browser die adresse "t-online.de" ein, kann das netzwerk diese adresse nicht finden, baut der router eine verbindung in das WAN auf und sucht diese adresse dort.
    WinXP ist genauso wie Win2000 ein ausgesprochenes Netzwerk-betriebssystem welches beim start erst mal die gesamte netzwerkumgebung abscannt. mir scheint, dass ausgelöst durch diesen scan, der router erstmal online geht.
    ich habe schon versucht durch firewall-log-auswertung diese erscheinung nachzuweisen, gelingt aber nicht. die log-files geben keinerlei auskunft darüber.
    also wie gesagt, das ist meine persönliche erfahrung damit, wer es besser weiss, soll es hier posten.
    fazit: die flatrate sorgt für entspannung :mrgreen:

    P.S. möchte noch anfügen, dass nicht jeder router gleich "empfindlich" ist.
    mein SMC tut´s nich, hatte aber schon andere hier bei denen war´s so.
     
  4. Eleven

    Eleven Fachmann

    Registriert seit:
    16. Juni 2002
    Beiträge:
    214
    Punkte für Erfolge:
    16
    Mir scheint es hängt ziemlich stark mit dem "generic host process" zusammen. Dieser macht wohl u.a. die DNS Geschichte. Zu Zeiten meines FLI4l ist der Router nicht online gegangen, der hatte jedoch auch einen eigenen DNS Server um die WAN Abfragen zu verhindern.

    Wie es mit meinem Allnet jetzt ist kan ich nicht genau sagen - mir scheint aber schon das er sehr leicht in Netz geht und dafür umso schwerer wieder raus geht ;)

    Gruß,

    Eleven
     
  5. Samuel

    Samuel Experte

    Registriert seit:
    11. Juli 2002
    Beiträge:
    355
    Punkte für Erfolge:
    16
  6. smoker

    smoker Starter

    Registriert seit:
    18. August 2002
    Beiträge:
    3
    Punkte für Erfolge:
    1
    moin,

    @lars12

    installiere mal XP Antispy (3.61 (Deutsch))

    XPAntiSpy ist eigentlich nicht mehr als ein Tool, das Einstellungen am System vornimmt, die man, sofern man sie vornehmen will, auch manuell machen kann. Es macht das ganze nur automatisch. Diese Einstellungen, die dort gemacht werden, kursieren auf vielen User-Boards unter dem Namen 'Installationsanleitungen'. Eine dieser Installationsanleitungen gibt es bei NVinside.de. Es geht im Grunde genommen um Funktionen, die in Windows-Komponenten wie dem Internet Explorer eingebaut sind und dazu dienen, sich mit anderen Computern im Internet zu verbinden. Vorwiegend wollen sich diese Funktionen mit Microsoft verbinden, um z.B. Fehlerprotokolle nach einem schweren Programm/Systemfehler oder die Anfrage nach neuen Updates zu senden. Leider kann man nicht sagen, ob wirklich nur Fehlerprotokolle und Updateanfragen gesendet werden, und was diese für Daten über den Besitzer mitsenden. Ich habe diese Installationsanleitungen nicht geschrieben, aber ich habe mich damit beschäftigt, diese doch recht aufwändigen Schritte zu vereinfachen. Das ist dann der XPAntiSpy geworden. Die Einstellungen, die dieses Programm vornimmt, sind frei wählbar und beim Start auf die empfohlenen voreingestellt. Benutzer, die also mehr über diese Betriebssystem und seine Anforderungen daran wissen, können diese Einstellungen an ihre Vorstellungen anpassen. Das Programm hätte genausogut in Form einer Batchdatei daherkommen können, nur wäre die Bedienung dann wesentlich komplizierter gewesen.
    Das Programm ist eine einzelne, ausführbare Datei, die nicht installiert werden muss.
    Die Einstellung, die das Tool vornimmt, können selbstverständlich auch wieder Rückgängig gemacht werden.

    Das Tool 'xp-AntiSpy' ist Freeware und damit absolut Kostenlos für Private nutzung.

    grüsse

    cu
     
  7. Eleven

    Eleven Fachmann

    Registriert seit:
    16. Juni 2002
    Beiträge:
    214
    Punkte für Erfolge:
    16
    Das Tool ist doch die Grundlage eines jeden XP-Benutzers, oder ?? ;) ;)

    Hier vielleicht noch ein Link zum Download: www.rattenjungs.de

    Gruß,

    Eleven
     
  8. heavybyte

    heavybyte Super-User

    Registriert seit:
    27. Dezember 2001
    Beiträge:
    2.484
    Punkte für Erfolge:
    56
    hi jungs,
    glaubt ihr wirklich ich sei so blöd und würde das ausser acht lassen?
    der vorgang der hier beschrieben wird ist, dass noch während des windows-starts (da telefoniert noch niemand nach hause) der router online geht und zwar just zu einem zeitpunkt wo das netzwerk initialisiert wird. dieses ist nicht bei allen routern zu beobachten, weshalb ich zu dem schluss kam, dass es unterschiedliche "empfindlichkeiten" geben muss.
    diese vorgänge sind zwar in den log-files festgehalten, da steht aber nur dass und nicht warum der router online ging.
    also bitte bei antworten ein bisschen mehr technisches niveau!
     
  9. Samuel

    Samuel Experte

    Registriert seit:
    11. Juli 2002
    Beiträge:
    355
    Punkte für Erfolge:
    16
    Hallo Havybyte,

    Du hast bedingt recht den

    Der ist aber auch erst später da und nicht sofort beim Windowsstart eingebunden.
    Für den Satrtvorgang kam für mich das "nach Hause telefonieren" in betracht, da u.a. "svchost.exe" mit verschiedenen aufrufparametern gestartet wird.
    Zonalarm Pro weist bei mir 2x darauf hin :! Im Taskmanager ist der svchost .exe aber 5x zu finden :!
    Daher mein Telefonverdacht :idee:

    Samuel
     
  10. Eleven

    Eleven Fachmann

    Registriert seit:
    16. Juni 2002
    Beiträge:
    214
    Punkte für Erfolge:
    16
    Ja genau - und diese svhost ist der Generic Host Process for Win32 Services.
    Wenn ich diesem verbiete ins Netz zu gehen klappt mein DNS und internes Netzwerk nicht mehr.

    Die Frage ist natürlich, das ist auch das worauf Heavybyte hinaus will, wie weit schnüffelt der Prozess. Ist es ein abklopfen des LANs oder bis in die WAN Weiten hinaus.

    Die Frage ist auch, passiert vielleicht etwas bevor Zone Alarm gestartet wurde :?

    Gruß,

    Eleven
     
  11. heavybyte

    heavybyte Super-User

    Registriert seit:
    27. Dezember 2001
    Beiträge:
    2.484
    Punkte für Erfolge:
    56
    hi leutz,
    jetzt kommen wir langsam zu des pudels kern.
    ich glaube, Eleven ist da auf der richtigen spur.
    eines noch vorweg, ich glaube nicht, dass windows schon während der startphase (auch nicht mittels svchost) nach hause telefoniert. das wäre anderen institutionen (z.B. fachzeitschriften, den autoren von XP-antispy u.s.w.) schon aufgefallen, das muss man nicht selbst nochmal kontrollieren (obwohl ich microsoft gegenüber auch sehr misstrauisch bin). mit einem packet-sniffer käme man der sache schnell auf den grund.
    wenn windows telefonieren würde, müsste es auch eine DNS-anfrage an den router schicken. in diesem fall müssten sich alle router gleich verhalten, nämlich der anfrage folgen.
    das ist aber hier nicht der fall. es sieht ganz so aus, dass bei manchen routern (wie schon gesagt, mein jetziger BR tut´s nicht) der initialisierungs-scan ausreicht den router online zu bringen.
     
  12. Eddi1964

    Eddi1964 Starter

    Registriert seit:
    22. März 2002
    Beiträge:
    2
    Punkte für Erfolge:
    1
    Hi,

    bei meinem Allnet 129 habe ich zumindest die Möglichkeit, unter der Einstellung PPPoE - Connect - on Demand die automatische Verbindung auf "disable" zu setzen. Dann dürfte sich der Rechner auch nicht automatisch mit dem Internet verbinden. Wenn Du dann allerdings online gehen möchtest, mußt Du über die Routersoftware die Verbindung herstellen. Bei 'ner Flatrate würde ich also dann besser die Verbindungen zulassen, sofern eine Spyware auszuschließen ist. Auf jeden Fall sollte man 'ne Firewall wie Zonealarm installiert haben.

    Beste Grüße

    Eddi1964
     
  13. Eleven

    Eleven Fachmann

    Registriert seit:
    16. Juni 2002
    Beiträge:
    214
    Punkte für Erfolge:
    16
    Das mit dem Dial-On-Demand ist ja glaub ich bei fast jedem Rechner so.

    Es geht ja auch darum, bei z.B. Zeit-tarifierten DSL-Verbindungen den Router laufen lassen zu können ohne permanent die Verbindung an und aus schalten zu müssen um z.B. Mail zu checken.

    D.h. der Router sollte "einfache" Abfragen von Windows abfangen ohne sofort ins WAN zu gehen.

    Interessant ist dann eben genau in diesem Zusammenhang festzustellen was den Router dazu bewegt ins WAN zu gehen.

    Nächtliche Grüße,

    Eleven
     
  14. Hier nochmal der Text:

    Hallo,

    wie ich hier gelesen habe war/bin ich nicht der einzigste der mit diesem Problem zu
    kämfen hatte. Ich habe mir einige Wochen mit debug und einem Sniffer um die Ohren gehauen.
    bis ich den mir unerklärlichen DNS Anfragen meines Windoof Rechners auf die schliche
    gekommen bin.

    Das ganze ist ein beschissen aufgesetztes NetBios im Windows.
    Der Windoof Rechner fängt direkt nach dem Booten an über NetBios seine Nachbarn zu
    suchen und auszuhandeln wer Master für die NetBios Tabelle (Netzwerkumgebung) der
    Arbeitsgruppe wird. Wenn der Master für die Arbeitsgruppe ausgehandelt ist, schickt
    der Master DNS Anfragen und möchte den Arbeitsgruppennamen am DNS auflösen.
    Da der DNS keine Antwort auf diese "bescheuerte" Anfrage hat versucht es der Windoof
    Rechner immer und immer wieder.

    Die Lösung:
    Ich habe mir einfach in die hosts und die lmhosts die Arbeitsgruppe mit einer freien
    IP-Adresse aus meinem LAN eingetragen. Da Windoof vor der DNS Anfrage erst in der
    hosts und der lmhosts nachschaut und dort fündig wird schickt er keine DNS Anfragen
    mehr.

    MfG
    0815